CentOS Bug Tracker
CentOS Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006721Xen4[CentOS-6] kernelpublic2013-11-04 22:172014-01-10 12:50
Reporterdustymabe 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version[CentOS-6] 6.4 
Target VersionFixed in Version 
Summary0006721: bnx2x firmware missing from kernel-3.4.61-9.el6.centos.alt
DescriptionAfter following the instructions here
http://wiki.centos.org/HowTos/Xen/Xen4QuickStart [^] and installing the
kernel from Xen4 CentOS project
(kernel-3.4.61-9.el6.centos.alt.x86_64) I can't use any networking
because the firmware for my NIC is not available:

Bringing up interface eth0.3: bnx2x 0000:02:00.0: firmware:
requesting bnx2x/bnx2x-e1h-7.2.51.0.fw
bnx2x: [bnx2x_init_firmware:11696(eth0)]Can't load firmware file
bnx2x/bnx2x-e1h-7.2.51.0.fw
bnx2x: [bnx2x_func_hw_init:5476(eth0)]Error loading firmware
bnx2x: [bnx2x_nic_load:2118(eth0)]HW init failed, aborting

This seems similar to this bug regarding bnx2 driver (http://bugs.centos.org/view.php?id=6513 [^]).
Steps To ReproduceFollow instructions at http://wiki.centos.org/HowTos/Xen/Xen4QuickStart [^] and notice networking does not work after installing kernel and kernel-firmware for 3.4.61-9.el6.centos.alt.x86_64.
TagsNo tags attached.
Attached Files

- Relationships
related to 0006609resolvedJohnnyHughes no network with bnx2x nic and 3.4.53-8.el6.centos.alt.x86_64 kernel 
related to 0006513resolvedJohnnyHughes No network with bnx2 nic and kernel-3.4.46-8.el6 

-  Notes
(0018304)
JohnnyHughes (administrator)
2013-11-06 14:08

broadcom networking is not good in most of the newer kernels. I will add in this specific driver to linux-3.4.68 kernel that I will release in the next day or so.
(0018306)
JohnnyHughes (administrator)
2013-11-06 22:08

fixed in 3.4.68-9 kernel which is now released
(0018338)
JohnnyHughes (administrator)
2013-11-12 17:36

there was a problem with the included patch ... will fix in the next built kernel
(0018353)
JohnnyHughes (administrator)
2013-11-14 15:07

Take a look at the testing kernel here:

http://dev.centos.org/centos/6/xen-c6-RC1/ [^]

That is a new 3.10.18 kernel and it should have the module.
(0018367)
dustymabe (reporter)
2013-11-19 16:02

I have confirmed the module that was previous missing (bnx2x/bnx2x-e1h-7.2.51.0.fw) in the 3.4.61-9.el6.centos.alt is present in the new new 3.10.18 kernel. However this still does not solve my problem as now my system with the newer kernel is looking for a new firmware:

bnx2x: [bnx2x_init_firmware:12263(eth0)]Can't load firmware file
bnx2x/bnx2x-e1h-7.8.17.0.fw
(0018409)
dustymabe (reporter)
2013-11-25 20:48

All necessary firmware seems to be included in the kernel-firmware rpm for kernel-3.10.20-11.el6.centos.alt.x86_64.

Thanks
(0018417)
tigalch (developer)
2013-11-26 18:58

Marking as resolved per reporters feedback. CEEA http://lists.centos.org/pipermail/centos-announce/2013-November/020030.html [^]

- Issue History
Date Modified Username Field Change
2013-11-04 22:17 dustymabe New Issue
2013-11-06 14:08 JohnnyHughes Note Added: 0018304
2013-11-06 22:08 JohnnyHughes Note Added: 0018306
2013-11-06 22:08 JohnnyHughes Status new => resolved
2013-11-06 22:08 JohnnyHughes Resolution open => fixed
2013-11-12 17:36 JohnnyHughes Note Added: 0018338
2013-11-12 17:36 JohnnyHughes Status resolved => acknowledged
2013-11-14 15:07 JohnnyHughes Note Added: 0018353
2013-11-19 16:02 dustymabe Note Added: 0018367
2013-11-25 20:48 dustymabe Note Added: 0018409
2013-11-26 18:58 tigalch Note Added: 0018417
2013-11-26 18:58 tigalch Status acknowledged => resolved
2014-01-10 12:50 JohnnyHughes Relationship added related to 0006609
2014-01-10 12:50 JohnnyHughes Relationship added related to 0006513


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker