View Issue Details

IDProjectCategoryView StatusLast Update
0010176CentOS-7kernelpublic2016-02-18 17:40
Reporterjszigetvari 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx86-64OSCentOSOS Version7.2
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0010176: kernel crashes on boot
DescriptionKernel crash on boot with HP ProLiant Microserver N36L + software raid 5

The last message I am able to see is "Swtiching to clocksource hpet"

Once, I saw the message:
Kernel panic - not syncing: Watchdog detected hard LOCKUP on cpu

On the last two occasions, I was presented with the following two backtraces:
http://pasteboard.co/Qsiu7FX.jpg
http://pasteboard.co/QskbGb2.jpg
Steps To Reproducekernel-3.10.0-327.4.4.el7.x86_64 crashes
kernel-3.10.0-327.3.1.el7.x86_64 crashes

kernel-3.10.0-229.20.1.el7.x86_64 is the last kernel that worked for me
Additional InformationThe issue seems similar to https://bugs.centos.org/view.php?id=9940 at first glance, however kernel-3.10.0-327.4.4.el7.x86_64 doesn't resolve the problem, so it may very well be a completely different problem.

I have also tried adding the debug option to the kernel command line, but it didn't improve the situation as was mentioned in https://bugs.centos.org/view.php?id=9940 .

My system employs a soft-RAID1 mirror for swap and /boot, and / resides on a soft-RAID5 array.

TagsNo tags attached.
abrt_hash
URL

Relationships

duplicate of 0009860 resolvedtoracat 3.10.0-327.el7 crashes on boot 

Activities

jszigetvari

jszigetvari

2016-01-16 21:28

reporter   ~0025380

Let me know if I can help with further debugging the issue.
clinton.fray

clinton.fray

2016-01-18 16:15

reporter   ~0025388

I'm experiencing the same issue (CentOS Linux release 7.2.1511 (Core)
). When I use the 3.10.0-229.14.1.el7.x86_64 image then CentOS works.
clinton.fray

clinton.fray

2016-01-18 16:35

reporter   ~0025389

Just an additional observation: I'm using the HP Proliant MicroServer N40L
tru

tru

2016-01-18 20:20

administrator   ~0025396

probably related to https://bugs.centos.org/view.php?id=9860

What kind of CPU does your N36L and N40L have?
clinton.fray

clinton.fray

2016-01-18 20:29

reporter   ~0025397

CPU: AMD Turion(tm) II Neo N40L Dual-Core Processor. I've checked the link you provided, yes it could be related. Thank you.
jszigetvari

jszigetvari

2016-01-18 20:29

reporter   ~0025398

The Microserver N36L has the following CPU:
http://paste.ubuntu.com/14569905/
jszigetvari

jszigetvari

2016-01-18 20:41

reporter   ~0025399

I have verifed that adding the "initcall_blacklist=clocksource_done_booting" string to the kernel command line works around the issue, thus this bug is a duplicate of https://bugs.centos.org/view.php?id=9860
tru

tru

2016-01-18 21:38

administrator   ~0025401

thanks for confirming :)
nroskam

nroskam

2016-01-25 02:55

reporter   ~0025500

I can also confirm that adding "initcall_blacklist=clocksource_done_booting" string to the grub profile and re-making the grub.cfg has finally resolved my booting issues with the latest kernels.

The last kernel that worked for me without this boot parameter was 3.10.0-229.14.1 on my HP N54L microserver. Now I run the latest 3.10.0-327.4.4 without problem.
toracat

toracat

2016-02-18 17:40

manager   ~0025772

Resolved. Please see bug #9860 for details.

Issue History

Date Modified Username Field Change
2016-01-16 21:27 jszigetvari New Issue
2016-01-16 21:28 jszigetvari Note Added: 0025380
2016-01-18 16:15 clinton.fray Note Added: 0025388
2016-01-18 16:35 clinton.fray Note Added: 0025389
2016-01-18 20:20 tru Note Added: 0025396
2016-01-18 20:29 clinton.fray Note Added: 0025397
2016-01-18 20:29 jszigetvari Note Added: 0025398
2016-01-18 20:41 jszigetvari Note Added: 0025399
2016-01-18 21:38 tru Note Added: 0025401
2016-01-18 21:38 tru Relationship added duplicate of 0009860
2016-01-25 02:55 nroskam Note Added: 0025500
2016-02-18 17:40 toracat Note Added: 0025772
2016-02-18 17:40 toracat Status new => resolved
2016-02-18 17:40 toracat Resolution open => fixed