View Issue Details

IDProjectCategoryView StatusLast Update
0001062CentOS-4Otherpublic2009-01-29 21:36
Reporterdhs 
PrioritynormalSeverityblockReproducibilityalways
Status closedResolutionfixed 
Product Version4.2 - i386 
Target VersionFixed in Version 
Summary0001062: smbmount not working properly - smb_retry: no connection process
DescriptionUsing samba-client-3.0.10-1.4E.2, I get a 30 second
delay when attaching (mount -t smbfs) a windows share to my linux box.
While it eventually succeeds, I get the following associated ring kernel
errors:

smb_retry: no connection process
smb_add_request: request [xxxxxxxx, mid=0] timed out!
smb_delete_inode: could not close inode 2

xxxxxxxx means hexa numbers, like dead9b80, db7a2e80 etc.
Additional InformationFound another info http://www.usenetlinux.com/archive/topic.php/t-466198.html but I'm not able to install RPMs from Samba.org it asks for diffrent kerberos libraries.

********* trying to install RPMs from samba.org
[root@pcg224b ~]# rpm -Uhv samba-client-3.0.20b-1.i386.rpm samba-common-3.0.20b-1.i386.rpm
warning: samba-client-3.0.20b-1.i386.rpm: V3 DSA signature: NOKEY, key ID f17f9772
error: Failed dependencies:
        libgssapi_krb5.so.2(gssapi_krb5_2_MIT) is needed by samba-client-3.0.20b-1.i386
        libk5crypto.so.3(k5crypto_3_MIT) is needed by samba-client-3.0.20b-1.i386
        libkrb5.so.3(krb5_3_MIT) is needed by samba-client-3.0.20b-1.i386
        libkrb5support.so.0 is needed by samba-client-3.0.20b-1.i386
        libreadline.so.5 is needed by samba-client-3.0.20b-1.i386
        libgssapi_krb5.so.2(gssapi_krb5_2_MIT) is needed by samba-common-3.0.20b-1.i386
        libk5crypto.so.3(k5crypto_3_MIT) is needed by samba-common-3.0.20b-1.i386
        libkrb5.so.3(krb5_3_MIT) is needed by samba-common-3.0.20b-1.i386
        libkrb5support.so.0 is needed by samba-common-3.0.20b-1.i386

****** installed kerberos RPMs
[root@pcg224b ~]# rpm -qa | grep krb
pam_krb5-2.1.8-1
krb5-libs-1.3.4-17
krb5-workstation-1.3.4-17
TagsNo tags attached.

Relationships

related to 0001776 resolvedkbsingh@karan.org CentOS-5 kernel panic because of a bug in the cifs module 

Activities

dhs

dhs

2005-10-25 10:36

reporter   ~0002870

Last edited: 2005-10-25 10:38

well, after playing...
I have used this in my script:

mount -r //1xx.1xx.1xx.11/c$ /mnt/wwwfs -t smbfs -o username=username,iocharset=utf8,codepage=unicode,unicode

and it worked perfectly, all unicode symbols were fine. It seems that unicode parameter is not working anymore. When using this:

mount -r //1xx.1xx.1xx.11/c$ /mnt/wwwfs -o username=username,utf8

mount work pretty well and fast, no errors and timeouts, but unicode symbols are not ok. :o(

mjesus

mjesus

2006-02-07 18:31

reporter   ~0003154

Having similar problem with:

CentOs 4-2
arch alpha
kernel 2.6.9-22.0.2.EC compiled for iso88591

when mounting win2003 shares on unix side with option

iocharset=iso8859-1



kernel errors:


kernel: smb_add_request: request [fffffc010f9f3580, mid=109] timed out!
kernel: smb_add_request: request [fffffc0106a27580, mid=36851] timed out!
kernel: SMB connection re-established (-5)
....
kernel: smb_add_request: request [fffffc00be422080, mid=542] timed out!
kernel: smb_get_length: Invalid NBT packet, code=4b
kernel: smb_add_request: request [fffffc00bc47d100, mid=11995] timed out!
kernel: smb_add_request: request [fffffc00bc47d100, mid=11996] timed out!
kernel: smb_delete_inode: could not close inode 2772
kernel: smb_add_request: request [fffffc00bc47d100, mid=11997] timed out!
...

smbfs stops responding

Also tried dhs suggestion using only utf8, but smbfs doesnot translate correctly and same problem occours.
dhs

dhs

2006-02-08 10:41

reporter   ~0003158

Last edited: 2006-02-08 10:41

I suggest to set the issue status to resolved/closed.

Solution is to use mount like this:
mount -r //1xx.1xxx.1xx.11/c$ /mnt/wwwfs -t cifs -o username=username,iocharset=utf8

Works pretty well.

mjesus

mjesus

2006-02-09 17:54

reporter   ~0003174

Last edited: 2006-02-09 17:55

unfortunately, cifs doesn't solve the problem, at least in alpha and X86_64 arches, with either utf8 or iso88591.

See bug 3404 in samba.cifs bugs report

https://bugzilla.samba.org/show_bug.cgi?id=3404

the problem might be kernel 2.6 itself, since everything works fine with 2.4

jim

jim

2006-02-13 18:02

reporter   ~0003186

See how to rebuild samba-3.0.21b-3.i386.rpm from the SRPMS. The errors in dmesg are reduced to a minimum. http://lists.centos.org/pipermail/centos/2006-February/019573.html
mjesus

mjesus

2006-02-13 18:52

reporter   ~0003187

Have already compiled samba-3.0.21b-3 for alpha arch. Besides not being possible to use the mount option in fstab due to error:

kernel: smbfs: mount_data version 1684370019 is not supported

which can be solved by using the smbmount command in e.g. rc.local,
the very same problem occours.

Some of the bugs were sorted with release samba-3.0.21b-1, see

https://bugzilla.samba.org/show_bug.cgi?id=3327

however the:

kernel: smb_add_request: request [(hex code), mid=xxxx] timed out!

error persists and hangs the smbfs after a while.

This bug might not be a major problem for most users but for us its a major pain since we have thousands of hits per day in the smbfs.
mjesus

mjesus

2006-02-16 11:31

reporter   ~0003195

Further examination of the logs lead to the conclusion that the error responsible for hanging the ystem is of the type:

kernel: smb_get_length: Invalid NBT packet, code=xx
matt

matt

2006-04-04 06:14

reporter   ~0003342

Please try installing krb5-devel
jo_hamburg

jo_hamburg

2006-04-09 18:48

reporter   ~0003373

occurs also with VMware and CentOS 4.3 (client + server)

kernel-2.6.9-34.EL
samba-3.0.22-1
krb5-devel-1.3.4-27
VMware-server-e.x.p-22874

message is

smb_add_request [...] timed out!

on the mountpoint remains an unusable and un-stat-able invalid entry
(which can be cleanly unmounted, however)
carenas

carenas

2007-05-21 08:06

reporter   ~0005205

problem still happening with Centos 4.4

  samba-client-3.0.10-1.4E.11
  kernel-smp-2.6.9-42.0.10.EL

the 30 second delay goes away if using samba.org's linked binary samba-client package (http://ftp.sernet.de/pub/samba/centos4-i386/):

  samba3-client-3.0.25-32

but the hangs persist
smooge

smooge

2007-07-26 19:48

reporter   ~0005704

Upstream is tracking it with

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168280

Problem seems to be waiting for U6 fix this fall.
JohnnyHughes

JohnnyHughes

2007-07-26 19:53

administrator   ~0005707

Also, this bug (the kernel: smb_get_length: Invalid NBT packet, code=4b part) looks related to cifs version 1.45. This will be updated to 1.48 soon.
tru

tru

2009-01-29 21:36

administrator   ~0008654

4.7 has cifs 1.50cRH

Issue History

Date Modified Username Field Change
2005-10-25 09:24 dhs New Issue
2005-10-25 10:36 dhs Note Added: 0002870
2005-10-25 10:37 dhs Note Edited: 0002870
2005-10-25 10:37 dhs Note Edited: 0002870
2005-10-25 10:38 dhs Note Edited: 0002870
2006-02-07 18:31 mjesus Note Added: 0003154
2006-02-08 10:41 dhs Note Added: 0003158
2006-02-08 10:41 dhs Note Edited: 0003158
2006-02-09 17:54 mjesus Note Added: 0003174
2006-02-09 17:55 mjesus Note Edited: 0003174
2006-02-13 18:02 jim Note Added: 0003186
2006-02-13 18:52 mjesus Note Added: 0003187
2006-02-16 11:31 mjesus Note Added: 0003195
2006-04-04 06:14 matt Note Added: 0003342
2006-04-09 18:48 jo_hamburg Note Added: 0003373
2007-05-21 08:06 carenas Note Added: 0005205
2007-07-26 19:48 smooge Note Added: 0005704
2007-07-26 19:48 smooge Status new => acknowledged
2007-07-26 19:53 JohnnyHughes Note Added: 0005707
2007-07-26 19:54 JohnnyHughes Relationship added related to 0001176
2007-07-26 19:54 JohnnyHughes Relationship deleted related to 0001176
2007-07-26 19:54 JohnnyHughes Relationship added related to 0001776
2009-01-29 21:36 tru Status acknowledged => closed
2009-01-29 21:36 tru Note Added: 0008654
2009-01-29 21:36 tru Resolution open => fixed