View Issue Details

IDProjectCategoryView StatusLast Update
0010843CentOS-6rpmpublic2016-05-13 00:55
Reporterrajeshrj Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
Platformx86_64OSCentOS OS Version6.4
Product Version6.4 
Summary0010843: OpenSSL l-1.0.1e rpmbuild fails since smime-certs expired .
DescriptionOpenSSL builds from source rpm on CentOS fails at cmd-test since smime-certs expired .

I have tried building below list of source rpm ’s which builds successfully but , failing since smile-certs expired recently .

openssl-1.0.1e-30.el6_6.7.src.rpm
openssl-1.0.1e-42.el6_7.2.src.rpm
openssl-1.0.1e-42.el6_7.4.src.rpm
openssl-1.0.1e-51.el7_2.4.src.rpm


$openssl-1.0.1e/test/smime-certs
smdsa1.pem
notAfter=May 10 13:53:09 2016 GMT
smdsa2.pem
notAfter=May 10 13:53:09 2016 GMT
smdsa3.pem
notAfter=May 10 13:53:09 2016 GMT
smdsap.pem

smroot.pem
notAfter=May 11 13:53:07 2016 GMT
smrsa1.pem
notAfter=May 10 13:53:08 2016 GMT
smrsa2.pem
notAfter=May 10 13:53:08 2016 GMT
smrsa3.pem
notAfter=May 10 13:53:09 2016 GMT
test/smime-certs

Can you please let me know if we have new openssl source RPM Patch updated with the new secure email certificates ?

I am looking for OpenSSL source rpm targeting CentOS 6.5 , 6.6 and 6.7

Kindly suggest the OpenSSL rpm with the fix .
Steps To Reproducerpmbuild using openSSL source rpms

Eg:
openssl-1.0.1e-30.el6_6.7.src.rpm
openssl-1.0.1e-42.el6_7.2.src.rpm
TagsNo tags attached.

Activities

rajeshrj

rajeshrj

2016-05-12 21:07

reporter   ~0026521

Error logs while building OpenSSL using openssl-1.0.1e-42.el6_7.2.src.rpm

------------------------------------------------
signed content DER format, RSA key: verify error
make: *** [test_cms] Error 1
make: Leaving directory `/rpmbuild/BUILD/openssl-1.0.1e/test'
error: Bad exit status from /var/tmp/rpm-tmp.7eLMzo (%check)



The test which fails is 'test_cms'
From Makefile
test_cms:
    @echo "CMS consistency test"
    $(PERL) cms-test.pl
toracat

toracat

2016-05-13 00:10

manager   ~0026522

This is a known issue and has been reported upstream:

https://bugzilla.redhat.com/show_bug.cgi?id=1335097
rajeshrj

rajeshrj

2016-05-13 00:55

reporter   ~0026523

Thanks for the update on the upsteam bug #1335097.
Do we get a Updated rpm with this fix included as patch from centos.org once bug #1335097 gets fixed ?

Issue History

Date Modified Username Field Change
2016-05-12 20:58 rajeshrj New Issue
2016-05-12 21:07 rajeshrj Note Added: 0026521
2016-05-13 00:10 toracat Note Added: 0026522
2016-05-13 00:55 rajeshrj Note Added: 0026523