View Issue Details

IDProjectCategoryView StatusLast Update
0010892CentOS-7kernelpublic2018-08-28 18:07
Reporterzhanhuaqing 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformCentOS-7-i386-Everything-1511OS3.10.0-327.el7.i686OS Version3.10.0-327.el7
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0010892: The kernel is only showing one CPU
DescriptionI installed the CentOS-7-i386-Everything-1511 on a HP ProLiant DL360 Gen9 server, it runs OK, but it is only showing one CPU, but the server actually has one Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz processor, which has 8 cores, and typer-threading is enabled, it should have 16 CPUs, but the kernel is only enabled one CPU.
Additional InformationHere are some messages from the /var/log/messages file:
May 19 09:11:23 swcentos7-rte kernel: smpboot: Allowing 1 CPUs, 0 hotplug CPUs
May 19 09:11:23 swcentos7-rte kernel: PM: Registered nosave memory: [mem 0x00094000-0x0009ffff]
May 19 09:11:23 swcentos7-rte kernel: PM: Registered nosave memory: [mem 0x000a0000-0x000dffff]
May 19 09:11:23 swcentos7-rte kernel: PM: Registered nosave memory: [mem 0x000e0000-0x000fffff]
May 19 09:11:23 swcentos7-rte kernel: e820: [mem 0x90000000-0xff7fffff] available for PCI devices
May 19 09:11:23 swcentos7-rte kernel: Booting paravirtualized kernel on bare hardware
May 19 09:11:23 swcentos7-rte kernel: setup_percpu: NR_CPUS:32 nr_cpumask_bits:32 nr_cpu_ids:1 nr_node_ids:1
May 19 09:11:23 swcentos7-rte kernel: PERCPU: Embedded 17 pages/cpu @f75d9000 s40000 r0 d29632 u69632
May 19 09:11:23 swcentos7-rte kernel: Built 1 zonelists in Zone order, mobility grouping on. Total pages: 4160743
May 19 09:11:23 swcentos7-rte kernel: Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.10.0-327.el7.i686 root=UUID=d28febf6-62e7-4ba3-93af-9c54d91ca6cb ro crashkernel=auto nomodeset rhgb quiet LANG=en_US.UTF-8

May 19 09:11:23 swcentos7-rte kernel: Hierarchical RCU implementation.
May 19 09:11:23 swcentos7-rte kernel: #011RCU restricting CPUs from NR_CPUS=32 to nr_cpu_ids=1.
May 19 09:11:23 swcentos7-rte kernel: #011Offload RCU callbacks from all CPUs
May 19 09:11:23 swcentos7-rte kernel: #011Offload RCU callbacks from CPUs: 0-31.

May 19 09:11:23 swcentos7-rte kernel: smpboot: weird, boot CPU (#0) not listed by the BIOS
May 19 09:11:23 swcentos7-rte kernel: Enabling APIC mode: Flat. Using 2 I/O APICs
May 19 09:11:23 swcentos7-rte kernel: ..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
May 19 09:11:23 swcentos7-rte kernel: smpboot: CPU0: Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz (fam: 06, model: 3f, stepping: 02)
May 19 09:11:23 swcentos7-rte kernel: Performance Events: PEBS fmt2+, 16-deep LBR, Haswell events, full-width counters, Broken BIOS detected, complain to your hardware vendor.
May 19 09:11:23 swcentos7-rte kernel: [Firmware Bug]: the BIOS has corrupted hw-PMU resources (MSR 38d is 330)
May 19 09:11:23 swcentos7-rte kernel: Intel PMU driver.
May 19 09:11:23 swcentos7-rte kernel: ... version: 3
May 19 09:11:23 swcentos7-rte kernel: ... bit width: 48
May 19 09:11:23 swcentos7-rte kernel: ... generic registers: 4
May 19 09:11:23 swcentos7-rte kernel: ... value mask: 0000ffffffffffff
May 19 09:11:23 swcentos7-rte kernel: ... max period: 0000ffffffffffff
May 19 09:11:23 swcentos7-rte kernel: ... fixed-purpose events: 3
May 19 09:11:23 swcentos7-rte kernel: ... event mask: 000000070000000f
May 19 09:11:23 swcentos7-rte kernel: Brought up 1 CPUs
May 19 09:11:23 swcentos7-rte kernel: smpboot: Total of 1 processors activated (5194.20 BogoMIPS)

May 19 09:11:23 swcentos7-rte kernel: pci 0000:ff:1e.3: [Firmware Bug]: reg 0x10: invalid BAR (can't size)
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 1/0x1 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 2/0x2 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 3/0x3 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 4/0x4 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 5/0x5 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 6/0x6 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 7/0x7 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 8/0x8 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 9/0x9 ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 10/0xa ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 11/0xb ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 12/0xc ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 13/0xd ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 14/0xe ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number
May 19 09:11:23 swcentos7-rte kernel: ACPI: NR_CPUS/possible_cpus limit of 1 reached. Processor 15/0xf ignored.
May 19 09:11:23 swcentos7-rte kernel: Unable to map lapic to logical cpu number


TagsNo tags attached.
abrt_hash
URL

Activities

zhanhuaqing

zhanhuaqing

2016-05-19 18:55

reporter  

messages (340,483 bytes)
zhanhuaqing

zhanhuaqing

2016-05-24 19:00

reporter   ~0026680

I installed CentOS-7-x86_64 on the same machine with the same BIOS configuration, all CPUs are activated. Here are some information:
dmesg | grep smp
[ 0.000000] smpboot: Allowing 16 CPUs, 0 hotplug CPUs
[ 0.037586] smpboot: CPU0: Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz (fam: 06, model: 3f, stepping: 02)
[ 0.051619] smpboot: Booting Node 0, Processors #1 #2 #3 #4 #5 #6 #7 #8 #9 #10 #11 #12 #13 #14 #15 OK
[ 0.316669] smpboot: Total of 16 processors activated (83104.28 BogoMIPS)

 dmesg | grep smp
[ 0.000000] smpboot: Allowing 16 CPUs, 0 hotplug CPUs
[ 0.037586] smpboot: CPU0: Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz (fam: 06, model: 3f, stepping: 02)
[ 0.051619] smpboot: Booting Node 0, Processors #1 #2 #3 #4 #5 #6 #7 #8 #9 #10 #11 #12 #13 #14 #15 OK
[ 0.316669] smpboot: Total of 16 processors activated (83104.28 BogoMIPS)
[root@swcentos7-rte ~]# dmesg | grep CPU
[ 0.000000] smpboot: Allowing 16 CPUs, 0 hotplug CPUs
[ 0.000000] setup_percpu: NR_CPUS:5120 nr_cpumask_bits:16 nr_cpu_ids:16 nr_node_ids:1
[ 0.000000] PERCPU: Embedded 30 pages/cpu @ffff88047fc00000 s91840 r8192 d22848 u131072
[ 0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=16, Nodes=1
[ 0.000000] RCU restricting CPUs from NR_CPUS=5120 to nr_cpu_ids=16.
[ 0.000000] Experimental no-CBs for all CPUs
[ 0.000000] Experimental no-CBs CPUs: 0-15.
[ 0.008820] CPU: Physical Processor ID: 0
[ 0.008820] CPU: Processor Core ID: 0
[ 0.009571] mce: CPU supports 22 MCE banks
[ 0.009601] CPU0: Thermal monitoring enabled (TM1)
[ 0.037586] smpboot: CPU0: Intel(R) Xeon(R) CPU E5-2640 v3 @ 2.60GHz (fam: 06, model: 3f, stepping: 02)
[ 0.065658] NMI watchdog: enabled on all CPUs, permanently consumes one hw-PMU counter.
[ 0.316665] Brought up 16 CPUs
[ 0.651855] microcode: CPU0 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651860] microcode: CPU1 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651864] microcode: CPU2 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651868] microcode: CPU3 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651871] microcode: CPU4 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651876] microcode: CPU5 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651880] microcode: CPU6 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651885] microcode: CPU7 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651889] microcode: CPU8 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651893] microcode: CPU9 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651897] microcode: CPU10 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651900] microcode: CPU11 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651905] microcode: CPU12 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651909] microcode: CPU13 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651913] microcode: CPU14 sig=0x306f2, pf=0x1, revision=0x35
[ 0.651917] microcode: CPU15 sig=0x306f2, pf=0x1, revision=0x35

So it seems the CentOS-7-i386 does not support this HP ProLiant DL380 Gen9, we have some hardware drivers that only support 32-bit Linux kernel, we are stuck in the i386 Linux. Also I noticed that the CentOS-7-x86_64 support UEFI boot mode, but the CentOS-7-i386 does not, and it is still using the legacy BIOS boot mode.

Is it possible for CentOS-7-i386 to fix the CPU issue?
fes

fes

2016-07-26 14:08

reporter   ~0027126

I had to disable the x2APIC feature in the firmware settings of the DL360 G9 in order for the CPU's to show up.

See also http://alext.mail.at/?p=298
zhanhuaqing

zhanhuaqing

2016-08-12 15:28

reporter   ~0027260

After disabled the x2APIC feature in the BIOS, it is now showing all the CPUs and the problem is resolved.
Thank you very much, fes!

Issue History

Date Modified Username Field Change
2016-05-19 18:55 zhanhuaqing New Issue
2016-05-19 18:55 zhanhuaqing File Added: messages
2016-05-24 19:00 zhanhuaqing Note Added: 0026680
2016-07-26 14:08 fes Note Added: 0027126
2016-08-12 15:28 zhanhuaqing Note Added: 0027260
2018-08-28 18:07 toracat Status new => resolved
2018-08-28 18:07 toracat Resolution open => fixed