View Issue Details

IDProjectCategoryView StatusLast Update
0010895CentOS-7kernelpublic2018-03-25 16:10
Reporterpremeau Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version7.2.1511 
Summary0010895: GCC version used to compile kernels does not match upstream.
DescriptionWhen upstream released their 7.2 updates, the kernel package included was complied with gcc 4.8.5 (the version gcc contained in 7.2).

CentOS has been releasing kernels compiled with the version of GCC included in 7.1, 4.8.3.

This has created module compatibility issues. The binary difference became a blocker when a team was exploring kpatch functionality.
Steps To ReproduceCompare /proc/version on kernels released since 7.2 was released, for example 3.10.0-327.13.1.el7.x86_64:

Upstream:
Linux version 3.10.0-327.13.1.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-4) (GCC) ) #1 SMP Mon Feb 29 13:22:02 EST 2016

CentOS:
Linux version 3.10.0-327.13.1.el7.x86_64 (builder@kbuilder.dev.centos.org) (gcc version 4.8.3 20140911 (Red Hat 4.8.3-9) (GCC) ) #1 SMP Thu Mar 31 16:04:38 UTC 2016


Tags7.3-QA
abrt_hash
URL

Relationships

child of 0008360 assignedtigalch Tracking bug for 7.next-release 

Activities

JohnnyHughes

JohnnyHughes

2016-09-19 17:07

administrator   ~0027528

Fixed in: kernel-3.10.0-327.36.1.el7

But, I do want to point out that because of Secure Boot and the associated tracking required for that (to be able to use the Microsoft generated secure boot cert) .. it may not always happen in a timely manner that we are able to specifically update the gcc (or other packages) on the secure boot signing machine where we have to build kernels with secure boot.

This means that at times, the CentOS kernel may not match up gcc with upstream kernels. We apologize for the inconvenience, but we are not in complete control of the timeliness for this specific process as there are external factors.

Issue History

Date Modified Username Field Change
2016-05-20 17:09 premeau New Issue
2016-05-20 17:19 toracat Status new => acknowledged
2016-09-09 07:35 avij Relationship added child of 0008360
2016-09-09 23:10 toracat Tag Attached: 7.3-QA
2016-09-19 17:07 JohnnyHughes Note Added: 0027528
2016-09-19 17:07 JohnnyHughes Status acknowledged => resolved
2016-09-19 17:07 JohnnyHughes Resolution open => fixed