View Issue Details

IDProjectCategoryView StatusLast Update
0010927CentOS-6kernelpublic2017-04-06 18:23
ReporterJohnnyHughes 
PriorityhighSeveritymajorReproducibilityhave not tried
Status newResolutionopen 
PlatformAllOSCentOS-6OS Version6.8
Product Version 
Target VersionFixed in Version 
Summary0010927: kernel 2.6.32-642.el6 fails to load the ipv6 kernel modules, which causes other modules (lockd and others) to fail
DescriptionAfter update, the lockd kernel module fails with the following errors:
===============================================================
kernel: lockd: Unknown symbol unregister_inet6addr_notifier
kernel: lockd: Unknown symbol register_inet6addr_notifier
modprobe: FATAL: Error inserting nfs (/lib/modules/2.6.32-642.el6.x86_64/kernel/fs/nfs/nfs.ko): Unknown symbol in module, or unknown parameter (see dmesg)

================================================================

The issue seems to be that the ipv6 kernel module can not load, the file /etc/modprobe.d/ipv6.conf contains:

install ipv6 /bin/true

That line has to be removed.
Additional InformationPotential fixes:

1. Make sure ipv6 kernel module can load. If you have ipv6 configured, the line that causes the issue is likely not present.

2. Disable ipv6:

  a. Edit '/etc/modprobe.d/ipv6.conf' and change the contents to:

options ipv6 disable=1

   b. Turn off ipv6tables with the command:

chkconfig ip6tables off

3. You may also need to disable ipv6 by editing /etc/sysctl.conf and adding:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1

 
TagsNo tags attached.

Activities

jgjorgji

jgjorgji

2016-05-30 13:57

reporter   ~0026725

This affects us as-well and I'm interested in a solution that does not involve enabling ipv6. This has worked fine before this update so I'd consider it an unwanted behavior.
mlampe

mlampe

2017-04-06 18:23

reporter   ~0029034

There have been kernel modules that depend on ipv6 before, e.g.:

ipv6 336282 3 ib_ipoib,mlx4_ib,ib_addr

Disabling with 'install ipv6 /bin/true' has been a bad idea for quite some time now.

Use 'options ipv6 disable=1' as suggested. You will see

IPv6: Loaded, but administratively disabled, reboot required to enable

in your bootup messages. That's as dead as IPv6 gets these days.

Issue History

Date Modified Username Field Change
2016-05-26 12:21 JohnnyHughes New Issue
2016-05-26 12:29 JohnnyHughes Summary kernel 2.6.32-642.el6 fails to load the NFS kernel modules => kernel 2.6.32-642.el6 fails to load the ipv6 kernel modules, which causes other modules (lockd and others) to fail
2016-05-26 12:29 JohnnyHughes Description Updated View Revisions
2016-05-30 13:57 jgjorgji Note Added: 0026725
2017-04-06 18:23 mlampe Note Added: 0029034