View Issue Details

IDProjectCategoryView StatusLast Update
0001103CentOS-4Otherpublic2011-10-05 16:56
ReporterLuc Ducazu 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version4.1 - i386 
Target VersionFixed in Version 
Summary0001103: newgrp fails with password
DescriptionAs root, create a group and add a password
# groupadd lusers
# gpasswd lusers
[enter password]

As a normal user, log in to the new group using the password
$ newgrp lusers
Password: [enter correct password]
newgrp: Permission denied.
Additional InformationThis fails on FC3 as well, however it works on FC4 with the latest shadow-utils installed.
TagsNo tags attached.

Relationships

related to 0005167 newIssue Tracker CentOS-6 newgrp fails with password 

Activities

kbsingh@karan.org

kbsingh@karan.org

2005-11-19 03:01

administrator   ~0002942

an updated shadow-utils was pushed out today to the update repositories, can you verify that the problem still persists ?
Luc Ducazu

Luc Ducazu

2005-11-19 15:53

reporter   ~0002944

I installed shadow-utils-4.0.3-58.RHEL4 and tried again.
The problem seems to be persisting.
micha137

micha137

2010-02-16 21:23

reporter   ~0011011

Compare to http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=569899
linuxtrainer

linuxtrainer

2011-10-05 11:21

reporter   ~0013466

Problem still exists for CentOS Linux release 6.0 (Final).
Do solve the problem I compiled a new rpm out of shadow-utils-4.1.4.2-13.fc15.src.rpm, coming with fedora15 and made an update with the new package.
JohnnyHughes

JohnnyHughes

2011-10-05 16:54

administrator   ~0013472

Since EL-4 is in the "Production 3 Phase" of its lifetime upstream, this issue is likely never to be fixed.

See this link for info on fixes in the various phases:

http://access.redhat.com/support/policy/updates/errata/

Since the CentOS goal is an exact functionality rebuild, if the issues exists upstream, it will also exist in CentOS.
JohnnyHughes

JohnnyHughes

2011-10-05 16:56

administrator   ~0013473

This issue will likely not be fixed upstream, so will remain in CentOS as well.

Issue History

Date Modified Username Field Change
2005-11-17 23:40 Luc Ducazu New Issue
2005-11-17 23:40 Luc Ducazu Status new => assigned
2005-11-19 03:01 kbsingh@karan.org Note Added: 0002942
2005-11-19 15:53 Luc Ducazu Note Added: 0002944
2010-02-16 21:23 micha137 Note Added: 0011011
2011-10-05 11:21 linuxtrainer Note Added: 0013466
2011-10-05 15:38 toracat Relationship added related to 0005167
2011-10-05 16:54 JohnnyHughes Note Added: 0013472
2011-10-05 16:56 JohnnyHughes Note Added: 0013473
2011-10-05 16:56 JohnnyHughes Status assigned => closed
2011-10-05 16:56 JohnnyHughes Resolution open => won't fix