View Issue Details

IDProjectCategoryView StatusLast Update
0001110CentOS-4kernelpublic2005-11-23 10:10
Reporterstaffantj Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.2 - Alpha 
Summary0001110: Missing .c/.o files in kernel source distro
DescriptionTrying to build the as-shipped updated kernel (as a sanity check before doing some minor tweaking, adding reiserfs support, etc), it falls flat on it's face apparently through missing files:

[root@freeway 2.6.9-22.0.1.EC-alpha]# make
  CHK include/linux/version.h
  CHK include/asm-alpha/asm_offsets.h
make[1]: *** No rule to make target `init/main.o', needed by `init/built-in.o'. Stop.
make: *** [init] Error 2
[root@freeway 2.6.9-22.0.1.EC-alpha]# make modules
  CHK include/linux/version.h
  CHK include/asm-alpha/asm_offsets.h
make[1]: *** No rule to make target `arch/alpha/kernel/srm_env.c', needed by `arch/alpha/kernel/srm_env.o'. Stop.
make: *** [arch/alpha/kernel] Error 2
[root@freeway 2.6.9-22.0.1.EC-alpha]#

Same results after make oldconfig.
Additional InformationThe same appears to be true for the shipped 2.6.9-22.0.1.EC-smp-alpha kernel sources.
TagsNo tags attached.

Activities

upi@iki.fi

upi@iki.fi

2005-11-22 23:55

reporter   ~0002948

you seem to try to compile at /usr/src/kernels/* where the kernel-devel package _headers_ are located. These are for 3rd party software complation and not full kernel source -> not a bug.
JohnnyHughes

JohnnyHughes

2005-11-23 10:10

administrator   ~0002949

If you want to rebuild your kernel, you need to download the kernel SRPM.

Install it and go to the SPECS dir (usually /usr/src/redhat/SPECS) and issue the command:

rpmbuild -bp kernel-2.6.spec

Then you can configure your kernel in ../BUILD directory.

I would then make it an RPM buy moving the .config file into ../SOURCES to replace the current kernel-2.6.9-$ARCH.config file and then goto ../SPECS and rebuild the kernel with:

rpmbuild -bb kernel-2.6.spec

(I don't think you need to add --target to your line with alpha)

Issue History

Date Modified Username Field Change
2005-11-22 23:46 staffantj New Issue
2005-11-22 23:46 staffantj Status new => assigned
2005-11-22 23:55 upi@iki.fi Note Added: 0002948
2005-11-22 23:57 upi@iki.fi Resolution open => no change required
2005-11-22 23:58 upi@iki.fi Status assigned => resolved
2005-11-23 10:10 JohnnyHughes Note Added: 0002949