View Issue Details

IDProjectCategoryView StatusLast Update
0011226CentOS-7generalpublic2016-12-06 16:27
Reportertru Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version7.2.1511 
Summary0011226: CentOS-7-x86_64-DVD-1511.iso size exceed fat32 file size limit
DescriptionCentOS-7-x86_64-DVD-1511.iso is 4,329,570,304 bytes

The size limit for a usual fat32 formated usb key is 4,294,967,295 (2^32 − 1) bytes.

One can no longer copy the iso file without splitting it on a regular key.

Not sure what is the proper course of action.
Tags7.3-QA
abrt_hash
URL

Relationships

child of 0008360 assignedtigalch Tracking bug for 7.next-release 

Activities

user1999

2016-07-27 21:34

  ~0027144

I fail to see where is the problem here.

First of all, the iso is not meant to be COPIED AS A FILE to the USB key but to be TRANSFERRED AS IT IS via dd or a similar tool, making the USB stick bootable.

And second, ANY file in the world larger than 4GB will not be transferable to a regular FAT32 formatted disk, no matter if that disk ( or partition, for that matter ) is an USB key or something else. Incidentally my boss recently tried to backup his pst mailbox (don't ask !) to a stick and failed for this very reason until I told him to reformat the stick as NTFS.
toracat

toracat

2016-07-28 07:53

manager   ~0027149

Well, let me reopen this. ;-)

@wolfy,

Those are the veryreasons why Tru initiated this report. If the iso files are less than 4,329,570,304 bytes, they can be *copied* to a fat32 system.

Yes, there were several occasions in which I wanted to COPY a DVD image to a fat32-formatted USB key (e.g. to move iso files to a location with very slow connection, or to save some bandwidth, etc). I achieved this by splitting a file into multiple pieces. :)

So, the question is... will it be worthwhile limiting the file size when creating DVD isos because that may benefit users who want to COPY them?

user1999

2016-07-28 07:55

  ~0027150

No, it would not, IMNSHO. Split the file or use a proper filesystem, not a call from the 80s
tru

tru

2016-11-24 22:17

administrator   ~0027993

- usbkey are usually pre formatted as fat32.
- one does not always have the tool/knowledge to split the file
- one might not want reformat the key to ntfs if there is already data on it.

If that is feasible, why not do it for the next release?
If not, we just can warn about that limit before they waste their time, just imho.
toracat

toracat

2016-11-24 23:51

manager   ~0027994

+1 for making an effort to limit the size.
toracat

toracat

2016-12-06 16:27

manager   ~0028085

Looks like it is not possible to reduce the size for 7.3.1611. And the size tends to become larger with each new release. Now closing this ticket.

Issue History

Date Modified Username Field Change
2016-07-27 15:37 tru New Issue
2016-07-27 21:34 user1999 Note Added: 0027144
2016-07-27 21:34 user1999 Status new => closed
2016-07-27 21:38 user1999 Resolution open => no change required
2016-07-28 07:53 toracat Note Added: 0027149
2016-07-28 07:53 toracat Status closed => feedback
2016-07-28 07:53 toracat Resolution no change required => reopened
2016-07-28 07:55 user1999 Note Added: 0027150
2016-10-17 22:10 toracat Tag Attached: 7.3-QA
2016-11-19 20:33 toracat Relationship added child of 0008360
2016-11-24 22:17 tru Note Added: 0027993
2016-11-24 22:17 tru Status feedback => assigned
2016-11-24 23:51 toracat Note Added: 0027994
2016-12-06 16:27 toracat Status assigned => closed
2016-12-06 16:27 toracat Resolution reopened => won't fix
2016-12-06 16:27 toracat Note Added: 0028085