View Issue Details

IDProjectCategoryView StatusLast Update
0011278CentOS-7libpeaspublic2016-10-18 10:54
ReporterOlivierDelrieu 
PrioritynormalSeverityblockReproducibilityalways
Status newResolutionopen 
PlatformLinuxOSCentOSOS Version7.2.1511
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0011278: libpeas breaks gedit plugins
DescriptionMost of the gedit plugins distributed on this CentOS version ("Bracket Completion", "Character Map", "Code Comment", ...) cannot be used. The following error is reported:

(gedit:6807): libpeas-WARNING **: Error initializing Python Plugin Loader: PyGObject initialization failed
ImportError: could not import gobject (could not find _PyGObject_API object)

(gedit:6807): libpeas-WARNING **: Please check the installation of all the Python related packages required by libpeas and try again

(gedit:6807): libpeas-WARNING **: Loader 'python' is not a valid PeasPluginLoader instance

Moreover, the python3 plugin AdvancedFind, which worked in an earlier gedit version 3.10.4 on F20, now gives the following error message on CentOS 7 :

(gedit:30506): libpeas-WARNING **: The 'python3' plugin loader has not been enabled


OS : CentOS 7.2.1511
Kernel : 3.10.0-327.18.2.el7.x86_64
Gedit : 3.14.3-9.el7
libpeas : 1.12.1-1.el7
Steps To Reproduceyum install gedit gedit-plugins*

Open gedit
go to 'preferences' -> 'plugins'
select 'Bracket Completion'

TagsNo tags attached.
abrt_hash
URL

Activities

OlivierDelrieu

OlivierDelrieu

2016-08-09 14:03

reporter   ~0027236

Downgrading pygobject3 package solved the first issue (PyGObject initialization failed)

Regarding the second issue (python3 plugin loader) the way forward may be to recompile the libpeas package from source with the --enable-python3 flag. I tried, but was then unable to link the new object to gedit (out of my comfort zone).
philwyett_hemi

philwyett_hemi

2016-10-18 10:54

reporter   ~0027740

Reported and assigned at Red Hat.

https://bugzilla.redhat.com/show_bug.cgi?id=1293069

Issue History

Date Modified Username Field Change
2016-08-09 12:27 OlivierDelrieu New Issue
2016-08-09 14:03 OlivierDelrieu Note Added: 0027236
2016-10-18 10:54 philwyett_hemi Note Added: 0027740