View Issue Details

IDProjectCategoryView StatusLast Update
0012030CentOS-7anacondapublic2016-10-14 16:11
ReporterEthanSpitz 
PriorityimmediateSeveritycrashReproducibilityalways
Status newResolutionopen 
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0012030: AttributeError: 'NoneType' object has no attribute 'type' - anaconda
DescriptionSorry about the severity/priority, I'll let you guys reassign that...

Basically, every time I try to install, installation crashes I get an error, see additional information.

Base error message is:
AttributeError: 'NoneType' object has no attribute 'type' - anaconda
Steps To Reproduce* Boot from installation disk
* Select disk for automatic partitioning (I'm using leftover space on a drive)
* Begin installation
* Crash

This is the most basic form, you can use any sort of configuration of packages.
Additional InformationSorry about this, didn't have a way to save the log. Took picture of screen :(

https://goo.gl/photos/Xd9Kb7mLMesdwhWe6

I'm also using the Everything ISO installed on a thumbdrive. I've tried multiple ports just in case it was related. I verified the sha256

Anyways, please let me know if there's anyway I can help capture more information for you guys. It happens every time no matter my configuration.
Tagscrash, installation
abrt_hash
URL

Activities

EthanSpitz

EthanSpitz

2016-10-14 03:08

reporter   ~0027709

I want to add that I'm using Rufus 2.11.995 to create the bootable disk image with the ISO image option.

I also tried the minimal install image and it has the same issue.

I'm going to try creating the bootable image using DD image with Rufus instead and will update.
EthanSpitz

EthanSpitz

2016-10-14 04:17

reporter   ~0027710

DD with rufus created a media check that failed every time. I even tried ignoring the media check failure and I get the same error.

I also tried different usb drives, still get the same error.

I'm not sure what else I can try other than burning it to disk, if I had one laying around.
EthanSpitz

EthanSpitz

2016-10-14 05:02

reporter   ~0027711

I used a live boot ubuntu disk and used dd on it to create a bootable usb drive. It passed media check, and failed the same way on install.

I figured I'd give an actual linux dd a try since I had looked through some other tickets and that had been a common fix.

Didn't work for me.

user1999

2016-10-14 13:29

  ~0027717

Last edited: 2016-10-14 13:34

View 2 revisions

Both linux dd ( which is indeed the recommended and supported way ) and Rufus are known to work correctly. If I were to guess, I'd say anaconda does not like "something" in the way your disk is formatted. I know of cases where removing the metadata leftover from previous RAID installations solved similar issues.
Unfortunately I do not know how to bypass the error in your case, since you want (and this perfectly legit!) to preserve the current content from the other partitions.

EthanSpitz

EthanSpitz

2016-10-14 16:08

reporter   ~0027718

I figured out what was causing it to crash, but I don't know the origins of why.

I took the same installation media I created and changed the installation source (or whatever it is called on the installer) and changed it from looking at my installation media, I gave it a URL for packages and it successfully installed.

I wouldn't call this "fixing the issue" by any means, but I was able to get CentOS installed this way.

It obviously has to do with how the installer is mounting the install USB or something of that sort that it can't find all the packages it wants to install on it.
EthanSpitz

EthanSpitz

2016-10-14 16:11

reporter   ~0027719

Also, I'd like to note that the destination was not a RAID, just a single disk that had a NTFS partition in the front of the disk with the rest empty.

I think this issue has to do with the USB.

Sorry for the multiple notes, but it doesn't appear I have the ability to edit my existing notes, and I'm a bit trigger happy with the add note button.

Issue History

Date Modified Username Field Change
2016-10-14 02:44 EthanSpitz New Issue
2016-10-14 02:44 EthanSpitz Tag Attached: crash
2016-10-14 02:44 EthanSpitz Tag Attached: installation
2016-10-14 03:08 EthanSpitz Note Added: 0027709
2016-10-14 04:17 EthanSpitz Note Added: 0027710
2016-10-14 05:02 EthanSpitz Note Added: 0027711
2016-10-14 13:29 user1999 Note Added: 0027717
2016-10-14 13:34 user1999 Note Edited: 0027717 View Revisions
2016-10-14 16:08 EthanSpitz Note Added: 0027718
2016-10-14 16:11 EthanSpitz Note Added: 0027719