View Issue Details

IDProjectCategoryView StatusLast Update
0012082CentOS-7kernelpublic2016-10-20 16:18
Reporteroomalley 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSCentOSOS Version7
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0012082: Disabling KSM Merging Memory Across NUMA Nodes Failes with "write error: Device or resource busy".
DescriptionUnable to disable KSM merging memory across NUMA nodes. I can read /sys/kernel/mm/ksm/merge_across_nodes but not write to it. For instance;


Reading Works;

cat /sys/kernel/mm/ksm/merge_across_nodes
1


Writing fails;

echo 0 > /sys/kernel/mm/ksm/merge_across_nodes
-bash: echo: write error: Device or resource busy


Similarly, attempting same change with virsh;

virsh node-memory-tune --shm-merge-across-nodes 0
error: Unable to change memory parameters
error: failed to set shm_merge_across_nodes: Operation not permitted

Steps To Reproduceecho 0 > /sys/kernel/mm/ksm/merge_across_nodes
-bash: echo: write error: Device or resource busy
Additional Informationuname -a
Linux XXXXXXXXXXXXXXX 3.10.0-327.28.2.el7.x86_64 #1 SMP Wed Aug 3 11:11:39 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

virsh --version
1.2.17
Tagskvm
abrt_hash
URL

Activities

oomalley

oomalley

2016-10-17 07:55

reporter   ~0027725

Also note, we have multiple KVM hosts configured pretty much identically, but this issue only affects a subset of them. All servers run the same package version sourced from an internal repo.

Rebooting does not resolve. Neither does stopping guest VMs and/or ksm and ksmtuned daemons.
oomalley

oomalley

2016-10-17 07:58

reporter   ~0027726

Qemu-KVM version 1.5.3 installed.
oomalley

oomalley

2016-10-20 01:38

reporter   ~0027756

Resolved, not a Bug.

/sys/kernel/mm/ksm/pages_shared must be 0 and theretofore first be unmerge with;
echo 2 > /sys/kernel/mm/ksm/run

See further discussion here;
https://www.centos.org/forums/viewtopic.php?f=47&t=59749

Issue History

Date Modified Username Field Change
2016-10-17 07:44 oomalley New Issue
2016-10-17 07:44 oomalley Tag Attached: kvm
2016-10-17 07:46 oomalley Tag Attached: ke
2016-10-17 07:46 oomalley Tag Detached: ke
2016-10-17 07:55 oomalley Note Added: 0027725
2016-10-17 07:58 oomalley Note Added: 0027726
2016-10-20 01:38 oomalley Note Added: 0027756
2016-10-20 16:18 toracat Status new => resolved
2016-10-20 16:18 toracat Resolution open => no change required