View Issue Details

IDProjectCategoryView StatusLast Update
0012095CentOS-7kernelpublic2018-01-25 05:23
Reporterphemmer 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSCentOSOS Version7
Product Version7.2.1511 
Target VersionFixed in Version 
Summary0012095: "ipt_CLUSTERIP: no such interface" when using network namespaces
DescriptionWhen network namespaces are in use, and you try to add a CLUSTERIP iptables rule on an interface inside a network namespace, it dumps the following error to the dmesg log:

    ipt_CLUSTERIP: no such interface myiface
Steps To Reproduceip netns add myns
ip link set dev myiface netns myns
ip netns exec myns iptables -I INPUT -d 1.2.3.4 -i myiface -j CLUSTERIP --new --clustermac 89:d4:47:eb:9a:fa --total-nodes 3 --local-node 1 --hashmode sourceip-sourceport
Additional InformationThis looks to have been fixed several years ago in the official linux kernel: https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/net/ipv4/netfilter/ipt_CLUSTERIP.c?id=d86946d2c5b4e519ffe435c2deeb2c9436ceb04f
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2016-10-17 21:52

manager   ~0027732

Because CentOS kernels cannot be modified (for other than debranding), the bug report needs to be filed upstream at http://bugzilla.redhat.com first. Once it is fixed there, CentOS will inherit it.

Normally patches like this are accommodated in the centosplus kernel, kernel-plus. However in this case, the referenced patch does not apply cleanly. Therefore, we cannot offer this solution.
phemmer

phemmer

2016-10-17 22:01

reporter   ~0027733

Filed upstream at https://bugzilla.redhat.com/show_bug.cgi?id=1385923
toracat

toracat

2016-10-17 22:07

manager   ~0027735

As always with kernel bug reports, it is marked private. If/when there is a progress, please share the info here. Thanks.
phemmer

phemmer

2017-02-07 22:14

reporter   ~0028543

Upstream bug report says the issue is fixed in kernel-3.10.0-558.el7, which is currently in QA
toracat

toracat

2018-01-25 05:23

manager   ~0031028

The patch is in the 7.4 kernel (3.10.0-693). Closing as resolved.

Issue History

Date Modified Username Field Change
2016-10-17 19:39 phemmer New Issue
2016-10-17 21:52 toracat Note Added: 0027732
2016-10-17 21:52 toracat Status new => acknowledged
2016-10-17 22:01 phemmer Note Added: 0027733
2016-10-17 22:07 toracat Note Added: 0027735
2017-02-07 22:14 phemmer Note Added: 0028543
2018-01-25 05:23 toracat Status acknowledged => resolved
2018-01-25 05:23 toracat Resolution open => fixed
2018-01-25 05:23 toracat Note Added: 0031028