View Issue Details

IDProjectCategoryView StatusLast Update
0012169Buildsyscommunity buildsyspublic2018-03-19 14:43
Reporterarrfab 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
Summary0012169: CBS builders fail to build images if kickstart is using new syntax
DescriptionThe builders have only pykickstart-1.99.43.13-2.el6.noarch (which is already a bump from 1.74.20-1.el6 [base] ) but they don't seem to understand new option :

see https://cbs.centos.org/koji/taskinfo?taskID=127951 :
"BuildError: Failed to parse kickstart file '/tmp/koji/tasks/7951/127951/centos7.ks' : The following problem occurred on line 71 of the kickstart file:

Unknown kickstart section: %addon"

So we should update to newer version to support those new options (and so ksvalidator working for os/imagefactory)
TagsNo tags attached.

Activities

lpancescu

lpancescu

2017-01-01 09:52

reporter   ~0028256

We now have a C7 builder, so I tried to disable kdump in centos/7 via kickstart, by adding "%addon com_redhat_kdump --disable" to the kickstart file. [1] But when I boot the test image I created, systemctl reports kdump as enabled, I found "%addon com_redhat_kdump --enable --reserve-mb='auto'" in /root/anaconda-ks.cfg, and I see no mention of kdump in the generated kickstart file. [2] Is something stripping away that section even before it reaches the C7 builder?

[1] https://cbs.centos.org/kojifiles/work/tasks/1110/151110/centos7.ks
[2] https://cbs.centos.org/kojifiles/work/tasks/1110/151110/koji-cloudinstance7-common-el7-build-151110-base.ks
arrfab

arrfab

2017-04-18 11:00

administrator   ~0029090

bug triage : image builders were updated to c7 so validating the kickstart now
arrfab

arrfab

2017-04-18 12:12

administrator   ~0029091

it seems that ksvalidator is ran on kojihub (which is still c6) so it stripped what it doesn't understand before creating the task that is then caught by the c7 builder.
Waiting for a pykickstart pkg that can be bumped/built on c6
alphacc

alphacc

2017-07-19 12:37

developer   ~0029685

Did we fixed that ? I think we did :)
arrfab

arrfab

2017-07-19 13:29

administrator   ~0029688

CBS ImageFactory builder was migrated to CentOS 7 so no issue anymore
arrfab

arrfab

2017-07-25 08:17

administrator   ~0029725

Bug reopened, details at https://lists.centos.org/pipermail/centos-devel/2017-July/016021.html
arrfab

arrfab

2018-03-08 09:44

administrator   ~0031388

Discussion on the centos-devel list was stopped and probably discussed over irc, but doing "bug triage" and I'd like to know if that's now solved
Waiting on feedback then closing if it's now good
lpancescu

lpancescu

2018-03-13 22:19

reporter   ~0031429

Sorry for taking so long to answer. Our current version of pykickstart still strips the %addon section from the generated kickstart, but upstream committed a fix on 2017-07-10 (2 commits). Perhaps we could patch our version or use the latest upstream version?

[1] https://cbs.centos.org/kojifiles/work/tasks/8022/358022/koji-cloudinstance7-common-el7-build-358022-base.ks
[2] https://github.com/clumens/pykickstart/issues/154
arrfab

arrfab

2018-03-14 08:30

administrator   ~0031430

So can you do a --scratch build for that pykickstart pkg ? that way we can test and report feedback upstream and also use it on our side in the meantime

Issue History

Date Modified Username Field Change
2016-10-28 11:03 arrfab New Issue
2017-01-01 09:52 lpancescu Note Added: 0028256
2017-04-18 11:00 arrfab Status new => resolved
2017-04-18 11:00 arrfab Resolution open => fixed
2017-04-18 11:00 arrfab Note Added: 0029090
2017-04-18 12:08 arrfab Status resolved => confirmed
2017-04-18 12:12 arrfab Note Added: 0029091
2017-07-19 12:37 alphacc Note Added: 0029685
2017-07-19 13:29 arrfab Status confirmed => resolved
2017-07-19 13:29 arrfab Note Added: 0029688
2017-07-25 08:17 arrfab Status resolved => acknowledged
2017-07-25 08:17 arrfab Note Added: 0029725
2018-03-08 09:44 arrfab Status acknowledged => feedback
2018-03-08 09:44 arrfab Note Added: 0031388
2018-03-13 22:19 lpancescu Note Added: 0031429
2018-03-14 08:30 arrfab Note Added: 0031430
2018-03-19 14:43 arrfab Status feedback => closed