View Issue Details

IDProjectCategoryView StatusLast Update
0012246Buildsyscommunity buildsyspublic2017-02-16 19:42
Reporterhhorak 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformaarch64OSCentOSOS Version7
Summary0012246: Aarch64 Tag/Target/Buildroot for devtoolset-6
DescriptionPlease, create tags/targets/buildroots for the devtoolset-6 SCL under SCLo SIG:

Use the -rh namespace and only aarch64 variant (x86_64 already exists). Create tags for centos7 only.

No other dependencies on other collections are needed (nothing in SCLo SIG exists on aarch64 anyway).
TagsNo tags attached.

Activities

alphacc

alphacc

2016-11-28 07:27

developer   ~0028009

We need to merge previous build (admin only operation) in this reverse order :

    devtoolset-6-valgrind-3.12.0-1.el7
    devtoolset-6-oprofile-1.1.0-4.el7
    devtoolset-6-gdb-7.12-24.el7
    devtoolset-6-gcc-6.2.1-3.1.el7
    devtoolset-6-binutils-2.27-10.el7
    devtoolset-6-6.0-6.el7
    devtoolset-6-systemtap-3.0-8s.el7
    devtoolset-6-elfutils-0.167-2.el7
    devtoolset-6-dyninst-9.2.0-4.el7
    devtoolset-6-make-4.1-3.el7
    devtoolset-6-strace-4.12-3.el7
    devtoolset-6-memstomp-0.1.5-5.el7
    devtoolset-6-ltrace-0.7.91-15.el7
    devtoolset-6-dwz-0.12-1.el7

Do we know if the packages are building correcly on arm64 ?

Is it ok to wait after 7.3 release ?

Or do you have a tighter deadline ?

--
Thomas.
hhorak

hhorak

2016-11-28 15:34

reporter   ~0028017

> We need to merge previous build (admin only operation) in this reverse order:

That comment reminds me I'm not totally sure how this might be done -- is it technically possible to build only aarch64 package if the same NVR is already available on x86_64?

And is the building step something you need to do as admin (because of merging) or should I do it once tags are prepared?

> Do we know if the packages are building correcly on arm64 ?

Yes, it should be fine.

> Is it ok to wait after 7.3 release ?
> Or do you have a tighter deadline ?

Actually this was requested by Evolution, so I'm personally fine with waiting. Jim might tell more.
Evolution

Evolution

2016-11-28 15:49

administrator   ~0028018

it's a bit of both. We can wait until after 7.3 is there, but there is a bit of a time crunch in the request. We'll need the packages built shortly after (say 2weeks?) 7.3.1611 is available.
alphacc

alphacc

2016-11-28 16:01

developer   ~0028019

As soon as we have 7.3 aarch64 available we can start, whether it is release or CR.
alphacc

alphacc

2017-01-05 14:21

developer   ~0028285

Hi Honza,

Hope you had a wonderful break and Happy New Year !

Can we resume this ?

Do we have an order to build all collections in ? What should we start with ?

--
Thomas.
hhorak

hhorak

2017-01-10 14:03

reporter   ~0028313

Oh, I owe an answer here, sorry :) Hope you had a great and Happy New Year as well!

I don't think we need to build any other SCL than devtoolset-6.. The order of builds in devtoolset-6 should be (hopefully) this:
devtoolset-6-6.0-6.el7
devtoolset-6-binutils-2.27-10.el7
devtoolset-6-dwz-0.12-1.el7
devtoolset-6-dyninst-9.2.0-4.el7
devtoolset-6-elfutils-0.167-2.el7
devtoolset-6-gdb-7.12-24.el7
devtoolset-6-ltrace-0.7.91-15.el7
devtoolset-6-make-4.1-3.el7
devtoolset-6-memstomp-0.1.5-5.el7
devtoolset-6-oprofile-1.1.0-4.el7
devtoolset-6-strace-4.12-3.el7
devtoolset-6-systemtap-3.0-8s.el7
devtoolset-6-gcc-6.2.1-3.1.el7
devtoolset-6-valgrind-3.12.0-1.el7
alphacc

alphacc

2017-01-10 14:29

developer   ~0028316

Can we be ambitious and try ppc64le at the same time ?
alphacc

alphacc

2017-01-10 14:30

developer   ~0028317

Can we be ambitious and try ppc64le at the same time ? If we know there are pending issue we can do it later.
hhorak

hhorak

2017-01-10 14:32

reporter   ~0028318

Why not, I don't know about any reasons why it shouldn't work, let's try it.
alphacc

alphacc

2017-02-16 19:42

developer   ~0028588

All done. devtoolset-6 ok for aarch64 and ppc64le

Issue History

Date Modified Username Field Change
2016-11-21 16:47 hhorak New Issue
2016-11-28 07:27 alphacc Note Added: 0028009
2016-11-28 15:34 hhorak Note Added: 0028017
2016-11-28 15:49 Evolution Note Added: 0028018
2016-11-28 16:01 alphacc Note Added: 0028019
2017-01-05 14:21 alphacc Note Added: 0028285
2017-01-10 14:03 hhorak Note Added: 0028313
2017-01-10 14:29 alphacc Note Added: 0028316
2017-01-10 14:30 alphacc Note Added: 0028317
2017-01-10 14:32 hhorak Note Added: 0028318
2017-02-16 19:42 alphacc Status new => resolved
2017-02-16 19:42 alphacc Resolution open => fixed
2017-02-16 19:42 alphacc Note Added: 0028588