View Issue Details

IDProjectCategoryView StatusLast Update
0012285CentOS CI[All Projects] generalpublic2020-01-29 16:39
Reporterroidelapluie 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0012285: Install the Jenkins Job DSL plugin
DescriptionJenkins Job builder is great ; however that project does not really have a future.

Indeed, Openstack abandonned recently Jenkins, and they were driving forces behind JJB.

I would suggest that install the best alternative available: Jenkins Job DSL

That Jenkins Job DSL plugin is community supported, much more maintained and used, for the same purposes as JJB.

Also, for the config management SIG, it is a better plugin than JJB because be are limited by the static nature of JJB. It makes use write "spaghetti yaml". We can prevent that by using Job DSL.


* We do not need to move the SIG away from JJB. Both can be run in parallel.
* If we have the Job dsl plugin, I would be happy to move my sig to it.
TagsNo tags attached.

Activities

bstinson

bstinson

2016-12-20 22:24

administrator   ~0028221

Added

Issue History

Date Modified Username Field Change
2016-11-29 15:04 roidelapluie New Issue
2016-12-20 22:24 bstinson Note Added: 0028221
2016-12-20 22:24 bstinson Status new => resolved
2016-12-20 22:24 bstinson Resolution open => fixed
2020-01-29 16:39 arrfab Project Buildsys => CentOS CI
2020-01-29 16:39 arrfab Category Ci.centos.org Ecosystem Testing => general