View Issue Details

IDProjectCategoryView StatusLast Update
0012572CentOS-7kernelpublic2017-09-21 16:07
Reportercebbert 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Platformx86_64OSOS Version
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0012572: kernel 3.10.0-514.2.2.el7.x86_64 oopses on boot
Descriptionkernel 3.10.0-514.2.2.el7.x86_64 oopses on boot. Does not happen in console mode boot (runlevel 3).
Steps To ReproduceBoot in graphics mode on Acer 5735 notebook
Tagskerneloops
abrt_hash
URL

Activities

cebbert

cebbert

2017-01-03 18:00

reporter  

20161216_090439_small.jpg (1,103,845 bytes)
cebbert

cebbert

2017-01-03 18:01

reporter   ~0028266

# lspci
00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16)
03:00.0 Network controller: Intel Corporation WiFi Link 5100
cebbert

cebbert

2017-01-03 18:16

reporter   ~0028267

static void process_one_work(struct worker *worker, struct work_struct *work)
__releases(&pool->lock)
__acquires(&pool->lock)
{
<------>struct pool_workqueue *pwq = get_work_pwq(work);
<------>struct worker_pool *pool = worker->pool;
<------>bool cpu_intensive = pwq->wq->flags & WQ_CPU_INTENSIVE;

oopses in line 2139 (above) in kernel/workqueue.c because pwq is NULL
...because get_work_pwq(work) in line 2137 returned NULL
...because the WORK_STRUCT_PWQ bit in work->data is not set
toracat

toracat

2017-01-03 19:10

manager   ~0028268

Does this look similar to your oops?

https://lkml.org/lkml/2014/9/29/465
cebbert

cebbert

2017-01-03 19:58

reporter   ~0028269

Yes, it looks the same. In that thread Tejun suggests enabling CONFIG_DEBUG_OBJECTS_WORK, which is enabled in kernel-debug. So I installed that package, and... it works perfectly (other than being a little slow.) I made sure I was running the 7.3 debug kernel instead of the 7.2 version I had fallen back to:

Linux version 3.10.0-514.2.2.el7.x86_64.debug
toracat

toracat

2017-09-17 17:46

manager   ~0030101

Do you still see the same issue with the EL 7.4 kernel?
cebbert

cebbert

2017-09-21 15:39

reporter   ~0030163

Seems to be fixed in the 7.4 kernels.
toracat

toracat

2017-09-21 16:07

manager   ~0030164

Thanks for the confirmation. Closing as 'resolved'.

Issue History

Date Modified Username Field Change
2017-01-03 18:00 cebbert New Issue
2017-01-03 18:00 cebbert File Added: 20161216_090439_small.jpg
2017-01-03 18:01 cebbert Note Added: 0028266
2017-01-03 18:16 cebbert Note Added: 0028267
2017-01-03 19:10 toracat Note Added: 0028268
2017-01-03 19:11 toracat Status new => feedback
2017-01-03 19:58 cebbert Note Added: 0028269
2017-01-03 19:58 cebbert Status feedback => assigned
2017-01-16 18:19 cebbert Tag Attached: kerneloops
2017-09-17 17:46 toracat Note Added: 0030101
2017-09-21 15:39 cebbert Note Added: 0030163
2017-09-21 16:07 toracat Status assigned => resolved
2017-09-21 16:07 toracat Resolution open => fixed
2017-09-21 16:07 toracat Note Added: 0030164