View Issue Details

IDProjectCategoryView StatusLast Update
0012597mirrorunclassifiedpublic2017-03-14 09:58
Reporterandynz2017 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformHyperVOSCentosOS Version7.3.1611
Summary0012597: yum install epel-release, yum update fails - mismatch requested URL versus what is in the repository
DescriptionRunning yum install epel-release is successful. Installation of epel-release breaks yum. On investigation, it appears that the requested FQDN on client side for two of the destination files does not match what is in the repository.

http://ucmirror.canterbury.ac.nz/linux/fedora/fedora-epel/7/x86_64/repodata/273d91af54359e55a0d6f254466eec1297a5c41af7574a3ba5937e20cbefbc5c-primary.sqlite.xz: [Errno 14] HTTP Error 404 - Not Found

epel/x86_64/updateinfo FAILED
http://ucmirror.canterbury.ac.nz/linux/fedora/fedora-epel/7/x86_64/repodata/30835c6dcc431734bfe90516122028230508df49312aa0f29456016c40a2226a-updateinfo.xml.bz2: [Errno 14] HTTP Error 404 - Not Found

Yum attempts other mirrors which are accessible through curl, HTTP Error 404 - Not found also returned from upstream repositories for all other attempts.

Browsing directly to the repo (http://ucmirror.canterbury.ac.nz/linux/fedora/fedora-epel/7/x86_64/repodata/repomd.xml) and reviewing both primary.sqllite.yz and updateinfo indicates different file names exist upstream to what the client is expecting to access.

On review of repomd.xml file on the upstream repo server, the file a href location appears to illustrate the same path in which the client is trying to access but the actual directory doesn't contain this file.

<data type="updateinfo"><checksum type="sha256">30835c6dcc431734bfe90516122028230508df49312aa0f29456016c40a2226a</checksum><open-checksum type="sha256">b7b1ae1149d38f8f23f232d0804078d1ccdb777a6f058e37714f8e199fe9ca37</open-checksum><location href="repodata/30835c6dcc431734bfe90516122028230508df49312aa0f29456016c40a2226a-updateinfo.xml.bz2"/>

Steps To ReproduceReproduce by:

yum remove epel-release
rm -rf /var/lib/rpm/__db*
yum clean all
yum update (without epel-release) successful
yum install epel-release
yum update
Additional InformationUnsure what the issue is here but it appears to be upstream across a wide variety of mirrors.

yum install epel-release installs noarch 7-6 yet another server that is completely up to date and working perfectly is using epel-release 7-8. Forcefully remove epel-release and installing epel-release 7-8 using rpm -i epel-release-7-8.noarch.rpm and manually restoring the key in /etc/pki/rpm-gpg/ does not help. Same issue.

Curious to know whether this issue is wider spread or if this is a local server issue. Out of ideas on what else to check.
Tagscentos 7

Activities

andynz2017

andynz2017

2017-01-08 06:39

reporter   ~0028298

Work around applied:

In /etc/yum.repos.d/epel.repo, commented out the following lines;
#mirrorlist=https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=$basearch

Enabled baseurl lines in configuration file and repointed to new repo.

baseurl=http://mirror.xnet.co.nz/pub/epel/7/$basearch

Yum update found that epel-release was out of date and updated to epel-release 7-8. Working as expected. Suspect issue with the mirror?
arrfab

arrfab

2017-03-14 09:58

administrator   ~0028848

Epel metalink issue, not related to CentOS mirrors/infra

Issue History

Date Modified Username Field Change
2017-01-08 06:17 andynz2017 New Issue
2017-01-08 06:17 andynz2017 Tag Attached: centos 7
2017-01-08 06:39 andynz2017 Note Added: 0028298
2017-03-14 09:58 arrfab Status new => closed
2017-03-14 09:58 arrfab Resolution open => fixed
2017-03-14 09:58 arrfab Note Added: 0028848