View Issue Details

IDProjectCategoryView StatusLast Update
0012841CentOS-7kernelpublic2017-02-27 17:27
Reporterkabe 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi686 Hyper-VOSCentOSOS Version7.3.1611
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0012841: dd disk I/O freeze running as Hyper-V guest
Description"dd count=257" freezes disk I/O when running CentOS 6.3.1611 i686 (AltArch) as
Hyper-V guest.
Steps To Reproduce- Prepare a Hyper-V instance (on Windows 10 Professional is enough)
- Load CentOS 7.3.1611 i686 DVD .iso as DVD image
- Boot with "inst.text" kernel option, to force text mode installation
- anaconda starts. Ignore the prompt, and switch to VT2 by Alt+F2
- enter in prompt:
root# dd if=/dev/zero of=/dev/sda count=257

The process freezes execution.
^C, ^Z, SIGKILL doesn't stop the process.
Additional InformationBut VTs are still alive, and you can switch to VT3 shell (Alt+F3).

/proc/*/status says:
State: D (disk sleep)

Another dd run from other VT will similary freeze the execution.

Up to "dd count=256" will run normally.
 
anaconda, during fresh installation, does
dd if=/dev/zero of=/dev/sda bs=512 seek=2048 count=2048
which stomps on this bug and sits there, without any feedback.

In rare occations, will panic at
kmem_cache_alloc+0x4d/0x1e0, but stack trace wasn't that useful.
Tagsi386, kernel
abrt_hash
URL

Activities

kabe

kabe

2017-02-20 07:06

reporter   ~0028610

CentOS 7.2.1511 kernel-3.10.0-327.el7.i686
(Johnny Hughes' near-vanilla kernel, not centos-plus)
does not have this problem.
I also tried with near-vanilla kernel-3.10.0-514.6.1 compiled with fixes in
https://bugs.centos.org/view.php?id=12412#c28183
but has the same problem.
Seems like a nasty regression.
kabe

kabe

2017-02-21 01:14

reporter   ~0028618

I've tried out in a real machine;
real ata_piix.ko and real pata_ali.ko machines does not hang.

Tried on Hyper-V, passing "ata_piix.prefer_ms_hyperv=0" kernel option.
No luck; does hang similary.
kabe

kabe

2017-02-22 04:11

reporter   ~0028629

Dugged up an upstream kernel.org commit, which fixed this bug:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=b0120d9906253570f593daf82016a5331bbee2b8

commit b0120d9906253570f593daf82016a5331bbee2b8
Author: Cathy Avery <cavery@redhat.com>
Date: Wed Nov 23 08:46:33 2016 -0500

    scsi: storvsc: Payload buffer incorrectly sized for 32 bit kernels.

I tried out this patch;
Applied to 3.10.0-514.6.1 kernel, respun the media,
and succeeded installing i686 distro as Hyper-V guest. No freeze.

Since this fix is 32bit specific, I don't think this will go into
upstream RHEL kernel codebase.
Could it be included in i686 centos-plus kernel?
toracat

toracat

2017-02-22 07:17

manager   ~0028632

Surely. We will include the patch in the next kernel update.
toracat

toracat

2017-02-23 16:46

manager   ~0028671

kernel-plus-3.10.0-514.6.2.el7.centos.plus is out. It has the patch from this bug report.
kabe

kabe

2017-02-27 04:20

reporter   ~0028694

Confirmed that updated kernel-3.10.0-514.6.2.el7.centos.plus.i686.rpm
(rebranded kernel-plus, right?)
does not hang the disk I/O on Hyper-V.
Respun installation disc installs as expected.

We could close this bugreport, but
how to spin a new installation disc with the updated kernel
is left as an excercise for the reader until 7.4.xxxx comes out.
toracat

toracat

2017-02-27 17:27

manager   ~0028699

Thanks for reporting back. Now closing as 'resolved'.

Issue History

Date Modified Username Field Change
2017-02-20 06:26 kabe New Issue
2017-02-20 06:26 kabe Tag Attached: i386
2017-02-20 07:06 kabe Note Added: 0028610
2017-02-20 07:08 kabe Tag Attached: kernel
2017-02-21 01:14 kabe Note Added: 0028618
2017-02-22 04:11 kabe Note Added: 0028629
2017-02-22 07:17 toracat Status new => assigned
2017-02-22 07:17 toracat Note Added: 0028632
2017-02-23 16:46 toracat Note Added: 0028671
2017-02-27 04:20 kabe Note Added: 0028694
2017-02-27 17:27 toracat Status assigned => resolved
2017-02-27 17:27 toracat Resolution open => fixed
2017-02-27 17:27 toracat Note Added: 0028699