View Issue Details

IDProjectCategoryView StatusLast Update
0012862Buildsyscommunity buildsyspublic2017-02-24 22:29
Reporterrmeggins 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0012862: [OpsTools SIG] need CBS tags hierarchy for opstools7-logging-
DescriptionWe need a CBS tags hierarchy with a prefix of opstools7-logging-. opstools7-logging-el7-build for build dependencies, and opstools7-logging-candidate etc. for the runtime packages.
TagsNo tags attached.

Activities

alphacc

alphacc

2017-02-22 15:21

developer   ~0028638

Hi,

The format is :
<sig><VER>-<project>-<release>

If this is release independent you can use the -common

opstools7-logging-common

let me know and ask for +1 for a SIG chair.

--
Thomas.
alphacc

alphacc

2017-02-22 15:23

developer   ~0028639

And btw what do you plan to build there ?
rmeggins

rmeggins

2017-02-22 15:23

reporter   ~0028640

We don't want -common, so I guess we'll take the <sig><VER>-<project>-<release> where <sig> is opstools, <project> is logging, and I'm not sure what should <release> be.
alphacc

alphacc

2017-02-22 16:09

developer   ~0028646

If you tell me what you plan to build we can try to figure out something.
alphacc

alphacc

2017-02-22 16:10

developer   ~0028649

What would version X.Y or <codename> ship ?
rmeggins

rmeggins

2017-02-22 16:14

reporter   ~0028650

This will be primarily used for fluentd, its plugins, and all of their build and run time dependencies. The first release will be fluentd 0.12.3x
alphacc

alphacc

2017-02-22 16:29

developer   ~0028654

I suggest

opstools7-fluentd-012

012 should be the major version you want to maintain (allowing users to stay on major release but getting minor / security fixes in the same repo)
e.g : 012 014 having a quick look at fluentd roadmap.

Also, please note that the target on the distribution server doesn't need to match the name, we could have fluentd tags and other ending up in the same yum repository.

Let me know if it is not clear.

Thomas.
rmeggins

rmeggins

2017-02-22 17:48

reporter   ~0028657

Thomas - ok - sounds good

Yeah, fluent 0.14 is going to be a headache - requires ruby 2.1 or later, and el7 only has ruby 2.0 - so some scl hoop jumping will be required . . .
alphacc

alphacc

2017-02-22 21:22

developer   ~0028659

Ok tags are created !

Issue History

Date Modified Username Field Change
2017-02-22 15:15 rmeggins New Issue
2017-02-22 15:21 alphacc Note Added: 0028638
2017-02-22 15:23 alphacc Note Added: 0028639
2017-02-22 15:23 rmeggins Note Added: 0028640
2017-02-22 16:09 alphacc Note Added: 0028646
2017-02-22 16:10 alphacc Note Added: 0028649
2017-02-22 16:14 rmeggins Note Added: 0028650
2017-02-22 16:29 alphacc Note Added: 0028654
2017-02-22 17:48 rmeggins Note Added: 0028657
2017-02-22 21:22 alphacc Status new => resolved
2017-02-22 21:22 alphacc Resolution open => fixed
2017-02-22 21:22 alphacc Note Added: 0028659