2017-10-23 18:45 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0012975CentOS-6openswanpublic2017-03-15 11:16
Reporterharman_cisco_test 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusnewResolutionopen 
PlatformDesktopOSCentOSOS Version6.8
Product Version 
Target VersionFixed in Version 
Summary0012975: Unable to create ipsec tunnel on centOS 6.8 after switching from openswan to libreswan
DescriptionHi,

We had a working tunnel between 2 systems using self signed certificates for authentication.
Now we shifted from openswan to libreswan and the same configuration stopped working.
Can you please help me out with why is the tunnel connection failing.
We have the same configuration that we used with openswan and everything worked fine but the same configuration fails with libreswan.

According to me there are some changes when it comes to creation tunnel with x509 Certificates using openswan and libreswan.
Can you guys please help.

Regards,
Tarun Dagar
Steps To Reproduce1. Bring up the tunnel using self signed certificates using openswan.
2. Now remove openswan and replace it with libreswan.
3. Perform the same steps performed on openswan on libreswan also.
4. Try to bring up the tunnel.
Additional InformationWe have been facing this issue for quite a long time now and google is not helping us in any way.
Please provide your worthy assistance.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2017-03-15 11:16 harman_cisco_test New Issue
+Issue History