View Issue Details

IDProjectCategoryView StatusLast Update
0001299CentOS-4Otherpublic2007-07-31 22:45
ReporterJohnnyHughes Assigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Product Versionunspecified 
Summary0001299: BackupPC in Testing Repo tracker
DescriptionPlease provide positive and negative feedback concerning BackupPC to this tracker.

TagsNo tags attached.

Activities

mbutters

mbutters

2006-06-08 00:41

reporter   ~0003551

Last edited: 2006-06-08 00:42

Unable to install package due to key problem. Perl-File-RsyncP has the same issue. Have installed two other packages from the same (testing) repo with no issues.


Downloading Packages:
warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 443e1821
Public key for backuppc-2.1.2-2.c4.centos.i386.rpm is not installed
Retrieving GPG key from http://dev.centos.org/RPM-GPG-KEY-CentOS-testing
GPG key at http://dev.centos.org/RPM-GPG-KEY-CentOS-testing (0x7203F491)
is already installed

The GPG keys listed for the "CentOS-4 Testing" repository are already installed
but they are not correct for this package.
Check that the correct key URLS are configured for this repository

JohnnyHughes

JohnnyHughes

2006-06-08 11:40

administrator   ~0003552

Last edited: 2006-06-08 11:41

some items in the centos-4 testing repo are signed by the main centos-4 key as well ...

http://mirror.centos.org/centos/RPM-GPG-KEY-CentOS-4

(obviously you are installing this not on CentOS-4 :)

.... or at least on a machine that has not installed any centos-4 updates

mbutters

mbutters

2006-06-08 12:18

reporter   ~0003553

Last edited: 2006-06-08 12:55

Testing done on fresh 4.3 install with no updates.
Erased PC and re-installed 4.3 and added updates. No issue with keys this time.

Now working on next issue. I can login and connect to the htpp://127.0.0.1/backuppc page and the menu appears on the left side but the message "Error: unable to connect to the BackupPC server" appears along the top of the page. I have added one host which also appears correctly in the left hand menu. Httpd.conf has been edited with user & group of "backuppc" as per instructions.

Message in var/log/messages :

Jun 9 00:32:31 localhost kernel: audit(1149769951.771:11): avc: denied { write } for pid=16278 comm="httpd" name="BackupPC.sock" dev=dm-0 ino=98191 scontext=root:system_r:httpd_t tcontext=root:object_r:var_lib_t tclass=sock_file

A search on google reveals others have struck this problem but I don't see a fix documented.

mbutters

mbutters

2006-06-21 10:46

reporter   ~0003582

Worked very well after I was over my initial unfamiliarity with this distro. Thanks for your efforts in packaging this. Currently backing up 3 windows clients running the backuppc version of the rsync daemon cygwin package. You might want to mention in the notes you have to disable SELinux protection for httpd or you will get the message 'Unable to connect to BackupPC server'.
JohnnyHughes

JohnnyHughes

2006-06-21 11:10

administrator   ~0003583

Thanks for the feedback ...

Are you using rsync to do the backups?

I probably also need to add to the documents that a .ssh directory needs to be created in the backuppc's home directory when doing ssh key pairs.
mbutters

mbutters

2006-06-21 12:21

reporter   ~0003584

no I'm using the rsyncd method with the cygwin package from here
http://sourceforge.net/project/showfiles.php?group_id=34854
This does not require the use of SSH. The clients are all on a private WAN anyway.
I might look at setting up SSH in the future for compressing the data as I have a few clients on slow WAN circuits. From what I read on the forums the RsyncP module does not support compression yet but SSH does.
It would be useful to have information on how to move your backup pool to another spindle ( hard drive ) as the package installs everything to one drive but the author recommends the pool be on a separate drive to the binaries, preferably raided.
mbutters

mbutters

2006-07-03 12:28

reporter   ~0003613

Having done 2 of these installations now I have noticed something odd about the server summary page. In comparing it to the screenshot in the documentation it is missing the "general server information" part of the server status page and a number of items from the navigation panel such as the "PC summary" link and the links to the config and hosts files. This may only be a fault in my installs but I thought it best to let you know in case it's due to the package setup and you just hadn't noticed it. I will attempt to upload a screenshot.

2006-07-03 12:29

 

Image2.gif (42,070 bytes)   
Image2.gif (42,070 bytes)   
mbutters

mbutters

2006-07-03 13:21

reporter   ~0003614

This turned out to be a simple fix. The package default value for CgiAdminUsers in config.pl is ''.
I had to change this value to 'admin'.
You may want to change this default so the admin pages work 'out of the box'.
ViperSBT

ViperSBT

2006-07-26 07:16

reporter   ~0003723

mbutters, I am running into the same problem that you have, can you help me with how you got around it?

messages:

Jul 26 00:07:36 localhost kernel: audit(1153897656.309:14): avc: denied { write } for pid=3324 comm="BackupPC_Admin" name="BackupPC.sock" dev=dm-0 ino=5767181 scontext=user_u:system_r:httpd_sys_script_t:s0 tcontext=user_u:object_r:root_t:s0 tclass=sock_file

I can't tell you how many hours I have spent trying to get BackupPC up and running, but I am so close now that I don't want to give up...
mbutters

mbutters

2006-07-26 11:09

reporter   ~0003725

In my case I fixed this disabling SELinux protection for the HTTPD daemon.
In KDE this is done by selecting System Settings, Security level and then selecting the SElinux tab and under "modify selinux policy" expand the HTTPD item and tick the box with the option "Disable SELinix proteection for HTTPD daemon".
You'll need to restart the httpd service ( or reboot )afterwards.
Ideally a directed policy for BackupPC would be best. Not sure if jhughes could incorporate this but it's beyond me ( poor windows admin that I am ). I would ensure your firewall doesn't allow web server access from the internet.
ViperSBT

ViperSBT

2006-07-26 13:05

reporter   ~0003726

Thank you VERY much! That did the trick...
grantm

grantm

2006-08-11 15:30

reporter   ~0003785

Johnny:
When you have time, can you update this to patch level 2 released on June 18? Thanks.
grantm

grantm

2006-08-15 21:20

reporter   ~0003794

I've gotten backuppc working to my liking. My initial issues were similar to those already listed:

1. Could not get it working with SELinux enabled (disabled for now)
2. Changed apache to run as backuppc user in httpd.conf
3. Set a CgiAdminUsers to 'admin' in config.pl

All of these are minor issues that kept it from working 'out of the box.'

By the way, I saw Johnny updated rpm to pl2 yesterday. I yum updated from pl1 with no problems.
JohnnyHughes

JohnnyHughes

2006-08-16 11:54

administrator   ~0003797

@grantm

I also upgraded several machines with no issues to the new patch set.

WRT the listed issues ...

I think I can (should) change the config.pl admin user ... but the other 2 issues you list I think are a documentation / requires sysadmin action ... do you agree.

(also mbutters comments?)

I think we can probably move this to extras with just a couple changes.
grantm

grantm

2006-08-16 14:25

reporter   ~0003800

Johnny:

I agree. Both 1 and 2 in my previous post will require manual configuration.

Look forward to seeing it in extras.
grant

grant

2007-07-31 20:46

reporter   ~0005772

Finally got around to upgrading from 2.x to 3.0 with yum. The only problem I had was getting used to the new config files location (/etc/BackupPC) and figuring out the changes in location and names for the per-pc configuration files. Read the docs for a refresher, and it's working now.

user430

2007-07-31 22:45

  ~0005773

Closing bug as there was only one negative feedback which seems to have been resolved by now.

Issue History

Date Modified Username Field Change
2006-04-10 18:25 JohnnyHughes New Issue
2006-04-10 18:25 JohnnyHughes Status new => assigned
2006-06-08 00:41 mbutters Note Added: 0003551
2006-06-08 00:42 mbutters Note Edited: 0003551
2006-06-08 11:40 JohnnyHughes Note Added: 0003552
2006-06-08 11:41 JohnnyHughes Note Edited: 0003552
2006-06-08 12:18 mbutters Note Added: 0003553
2006-06-08 12:55 mbutters Note Edited: 0003553
2006-06-21 10:46 mbutters Note Added: 0003582
2006-06-21 11:10 JohnnyHughes Note Added: 0003583
2006-06-21 12:21 mbutters Note Added: 0003584
2006-07-03 12:28 mbutters Note Added: 0003613
2006-07-03 12:29 mbutters File Added: Image2.gif
2006-07-03 13:21 mbutters Note Added: 0003614
2006-07-26 07:16 ViperSBT Note Added: 0003723
2006-07-26 11:09 mbutters Note Added: 0003725
2006-07-26 13:05 ViperSBT Note Added: 0003726
2006-08-11 15:30 grantm Note Added: 0003785
2006-08-15 21:20 grantm Note Added: 0003794
2006-08-16 11:54 JohnnyHughes Note Added: 0003797
2006-08-16 14:25 grantm Note Added: 0003800
2007-07-31 20:46 grant Note Added: 0005772
2007-07-31 22:45 user430 Status assigned => closed
2007-07-31 22:45 user430 Note Added: 0005773
2007-07-31 22:45 user430 Resolution open => fixed