2017-08-18 01:13 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0013125SCLo[All Projects] generalpublic2017-05-29 19:37
Reporterzaufi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSCentOSOS Version6
Summary0013125: `centos-sclo-rh-source` repository not found
DescriptionI'm trying to build a RPM package from spec with `yum-builddep` and got the following error:

Loaded plugins: fastestmirror, ovl
Loading mirror speeds from cached hostfile
 * base: ftp.heanet.ie
 * extras: ftp.heanet.ie
 * updates: ftp.heanet.ie
http://vault.centos.org/centos/6/sclo/Source/rh/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

Cannot retrieve repository metadata (repomd.xml) for repository: centos-sclo-rh-source. Please verify its path and try again
Steps To Reproduce1. yum-config-manager --enable centos-sclo-rh-source
2. yum update
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0029066

insmaheshw (reporter)

Hi,

This is happening because [centos-sclo-sclo-source] repository is enabled in CentOS-SCLo-scl.repo file.

Disable [centos-sclo-sclo-source] using below steps:

1. cd /etc/yum.repos.d/
2. vim CentOS-SCLo-scl.repo file
3. then disable the [centos-sclo-sclo-source] repository by replacing enabled=1 to 0

[centos-sclo-sclo-source]
name=CentOS-6 - SCLo sclo Sources
baseurl=http://vault.centos.org/centos/6/sclo/Source/sclo/
gpgcheck=1
enabled=0
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo

And if it is urgent for and want to use that centos-sclo-sclo-source repository then you have to change its baseurl path to below path if you are working on Centos 6.8:
http://vault.centos.org/6.8/sclo/Source/rh/

And by default [centos-sclo-sclo-source] repository is disabled in CentOS-SCLo-scl.repo file. Otherwise that path need to be change in centos-release-scl package.

Regards,
Shagun Maheshwari

~0029067

zaufi (reporter)

> And by default [centos-sclo-sclo-source] repository is disabled in CentOS-SCLo-scl.repo file.

Yep, and it still disabled for me! BUT, if you look at `/usr/bin/yum-builddep` from `yum-utils` package, for some unknown to me reason it will enable ALL source repos for corresponding binary repos... it is why I've got this error -- not because this repo enabled in my repo file!!!

~0029073

insmaheshw (reporter)

After disabling the [centos-sclo-sclo-source] repository, i am not able to reproduce this issue.So, Can you please share the steps to reproduce this issue ?

~0029092

hhorak (manager)

Thanks for reporting, I agree that http://vault.centos.org/centos/6/sclo/Source/rh should exist, now we need to figure out why it does not and how to fix it.. Adding some more people to CC, because I don't see bellow surface...

~0029093

hhorak (manager)

kbsingh/alphacc -- I think this will just require some change in configuration, do you need a separate issue for that (buildsys project) or is this report enough for you?

~0029094

zaufi (reporter)

@insmaheshw,

steps to reproduce:

1. please read the very first line of the bug description
2. make sure the repo [centos-sclo-sclo] is enabled (not a source one)
3. take any valid RPM spec file
4. try to execute `yum-builddep some.spec`

for further investigation please take a closer look around lines 95-96 (right after comment "Use source rpms") of `/usr/bin/yum-builddep` and then to function `setupSourceRepos()`... check how it disrespect your `enable=0` setting for source repos!

~0029095

insmaheshw (reporter)

@zaufi

I tried to reproduce this issue but still i am not getting error:
http://vault.centos.org/centos/6/sclo/Source/rh/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

Steps which i tried to reproduce this issue:

1. yum install centos-release-scl package because sclo repo was not available on my new 6.8 machine.
2. then i tried to execute this command: yum-builddeps abrt.spec

Its executed properly without any error. I am attaching logs of yum-builddeps command.

~0029348

hhorak (manager)

It looks like it is fixed now, http://vault.centos.org/centos/6/sclo/Source/rh/repodata/repomd.xml returns correct output, so closing. Feel free to re-open if anything else does not work.
+Notes

-Issue History
Date Modified Username Field Change
2017-04-12 19:39 zaufi New Issue
2017-04-13 12:03 insmaheshw Note Added: 0029066
2017-04-13 12:08 zaufi Note Added: 0029067
2017-04-14 05:15 insmaheshw Note Added: 0029073
2017-04-18 13:37 hhorak Note Added: 0029092
2017-04-18 13:44 hhorak Note Added: 0029093
2017-04-18 13:50 zaufi Note Added: 0029094
2017-04-18 14:22 insmaheshw File Added: yum-builddeps.log
2017-04-18 14:22 insmaheshw Note Added: 0029095
2017-05-29 19:36 hhorak Note Added: 0029348
2017-05-29 19:37 hhorak Status new => closed
2017-05-29 19:37 hhorak Resolution open => fixed
+Issue History