2017-10-20 14:23 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0013160CentOS-7kscreenpublic2017-09-14 15:27
Reporterdavmac 
PrioritynormalSeveritymajorReproducibilityrandom
StatusnewResolutionopen 
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0013160: Kscreen "permanently" disables only display
DescriptionOn several occasions I have left my workdesk and came back to find that the screen has gone black, with the monitor in power saving mode, and cannot be restored. I eventually found that switching to another virtual terminal (i.e. ctrl+alt+F2) worked and allowed me to login via the console, but switching back to the X session (KDE) immediately caused the monitor to enter power saving mode again and the display was off. Restarting did NOT help (the screen went black after logging in, i.e. when the KDE desktop started). The solution I found originally was to wipe my KDE config, i.e. ~/.kde directory.

Since then this has happened on two other occasions and by saving the config while in the "bad" state and comparing it to a "good" state I have determined that the problematic config file is for kscreen, specifically:

~/.kde/share/apps/kscreen/3bdd3e21723ff7304a65223ce1c8578b

The contents when the screen goes black are:

[ { "enabled" : false, "id" : "7ece8bcc219c1fa97f44a25814e1b62f", "metadata" : { "fullname" : "xrandr-Dell Inc.-DELL U2415-7MT016CE0D3S", "name" : "DP2" }, "pos" : { "x" : 0, "y" : 0 }, "primary" : true, "rotation" : 1 } ]

Naturally, it is the ("enabled" : false) that is the problem; if I edit this by hand to "true" and restart, my screen once again works correctly. Just to be clear, I have never manually specified that any screen should be off, however powersaving is active and the screen auto-blanks after some time. In most cases it resumes normally afterwards (when the mouse is moved or key pressed).

I suspect the problem occurs when the monitor is actually switched off before or after the power saving state is naturally entered, and will attempt to verify this, however I believe that in no case should Kscreen actually be disabling the monitor permanently without expressly being told to do so.
Steps To ReproduceAlthough I am uncertain of the precise steps and the problem has happened only occasionally, thoughts about how to reproduce are given in the Description field above.
Additional InformationAlthough this problem only happens occasionally, I consider it to be of major severity. A regular user might not realise that the text-mode console login was available and in any case might not be able to determine for themselves how to get out of the state where the screen goes black after logging in; furthermore the problem persists through reboot.
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes

~0029148

davmac (reporter)

Issue occurred again this morning; when I arrived at work the monitor was off and after switching it on the screen remained blank. I do not believe I turned the monitor off but it may have been turned off by someone else in the office or it may have turned itself off due to automatic powersaving (I suppose). I was able to restore it this time by:

1. Switching to an alternative virtual terminal and logging in
2. running: "sleep 1; DISPLAY=:0 xrandr --output DP2 --auto"
3. quickly switching to the X virtual terminal (before the "sleep 1" expired).

Note that /usr/libexec/kde4/kscreenlocker_greet was running and the screen was locked. I wonder if this may be significant. At some point *something* is causing the display to be disabled. I suspect that it may be that the monitor goes into a deep power-saving mode (or is switched off), and something then detects that the display is not connected, and it disables the output.

~0029964

eba (reporter)

I get the problem all the time, either when I go to sleep mode or when I leave the computer unattended for a while.

Here is the content of the file:
.kde/share/apps/kscreen/0ffbb31633b7dd9f7e0eb3748e467970

[ { "enabled" : false, "id" : "ff9c9e1ac316d3825232e2b01ab4128e", "metadata" : { "fullname" : "xrandr-Messeltronik Dresden GmbH-MD20435-16843009", "name" : "HDMI2" }, "pos" : { "x" : 0, "y" : 0 }, "primary" : true, "rotation" : 1 } ]

I have to login on another (text) terminal, edit the file and change "enabled" to true. Then I go back to the graphic terminal and unlock it the normal way.

I didn't have this problem with my previous computer (but same screen) which was running the latest Redhat. (Now I'm using CentOS 7.3)

~0030070

tigalch (manager)

Can you retry after the update to 7.4?

~0030078

eba (reporter)

The problem doesn't happen with the new kernels of version 7.4. If I reboot with a 7.3 kernel (either one), the issue is back.

The issue happened each time I switched off my screen. If I put the computer in sleep mode, I had to be careful not to switch off the screen before the computer was off, and to switch it back on, before the computer was on.
+Notes

-Issue History
Date Modified Username Field Change
2017-04-21 11:30 davmac New Issue
2017-04-25 09:15 davmac Note Added: 0029148
2017-08-29 18:59 eba Note Added: 0029964
2017-09-14 09:07 tigalch Note Added: 0030070
2017-09-14 15:27 eba Note Added: 0030078
+Issue History