View Issue Details

IDProjectCategoryView StatusLast Update
0013197CentOS-7cockpitpublic2018-11-24 15:03
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
PlatformLinuxOSCentOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0013197: cockpit should not require subscription manager
DescriptionThe cockpit-system package requires subscription-manager which creates annoying messages when running yum:

# rpm -q --requires cockpit-system | grep manage
subscription-manager >= 1.13

# yum update
Loaded plugins: fastestmirror, langpacks, product-id, search-disabled-repos, subscription-manager
This system is not registered with Subscription Management. You can use subscription-manager to register.
Steps To Reproduce1. yum install cockpit
2. yum update
TagsNo tags attached.




2018-05-20 21:22

reporter   ~0031876

This creates issues with Cockpit, where Cockpit thinks the system should be registered but isn't- so Cockpit will not look for any software updates.

Apparently the subscription-manager auto-enables yum plugins. So even if you disable the plugin, it will be enabled. The solution is running this:

subscription-manager config --rhsm.auto_enable_yum_plugins=0


2018-05-20 21:27

reporter   ~0031877

In some cases that solution works, in others it does not. Even with subscription-manager disabled, Cockpit still thinks it is active.


2018-10-26 13:05

reporter   ~0032999

# subscription-manager config --rhsm.auto_enable_yum_plugins=0
# yum update
Loaded plugins: fastestmirror, langpacks, product-id, search-disabled-repos,
              : subscription-manager
This system is not registered with an entitlement server. You can use subscription-manager to register.

Yup, doesn't work for me...

Is it even possible to have a subscription with CentOS? Wouldn't you just run RHEL instead?


2018-10-26 13:09

reporter   ~0033000

Apparently it is fixed upstream. See


2018-10-26 13:12

reporter   ~0033001

So with 7.6 this problem should fix itself?


2018-10-26 13:15

reporter   ~0033002

This will be fixed (according to that issue) whenever cockpit v180 is pulled in. The person on that issue thought that this would probably be with CentOS 7.6.

Maybe a candidate for backporting the fix?


2018-11-24 15:03

reporter   ~0033142

Well that was underwhelming...

I created a no-load meta package that had obsoletes/provides for subscription-manager-{rhsm,rhsm-certificates} which kinda worked. It now doesn't say it's not registered and will actually say there are updates available but that's it. You can't click on it and see the updates like I can on Fedora.

Issue History

Date Modified Username Field Change
2017-04-29 13:18 hobbes1069 New Issue
2018-05-20 21:22 JoshuaPK Note Added: 0031876
2018-05-20 21:27 JoshuaPK Note Added: 0031877
2018-10-25 21:33 toracat Category -OTHER => cockpit
2018-10-26 13:05 hobbes1069 Note Added: 0032999
2018-10-26 13:09 hjmallon Note Added: 0033000
2018-10-26 13:12 hobbes1069 Note Added: 0033001
2018-10-26 13:15 hjmallon Note Added: 0033002
2018-11-24 15:03 hobbes1069 Note Added: 0033142