2017-08-18 16:25 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0013276CentOS-7jasperpublic2017-05-18 15:07
Reportergeorge.wilson 
PriorityhighSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0013276: jasper-devel package not compiled properly
DescriptionTry and build a package with jasper devel (e.g. OpenCV) since the updates channel release of build 30.el7_3, open CV fails to compile with an error from the jasper module

This has been reported elsewhere (e.g. http://stackoverflow.com/questions/44038198/opencv-3-0-0-install-error-on-centos7)

Steps To ReproduceInstall jasper devel on centos 7 and then try and compile opencv (you will need other dependencies). With release 29.el7 it would compile since then release of 30.el7 yesterday (15/5/2017) it fails with the stacktrace below.
Additional InformationBuilding CXX object modules/photo/CMakeFiles/opencv_photo.dir/src/contrast_preserve.cpp.o
In file included from /usr/include/jasper/jasper.h:77:0,
                 from XXXXXX/opencv/modules/imgcodecs/src/grfmt_jpeg2000.cpp:59:
/usr/include/jasper/jas_math.h: In function 'bool jas_safe_size_mul(size_t, size_t, size_t*)':
/usr/include/jasper/jas_math.h:143:15: error: 'SIZE_MAX' was not declared in this scope
  if (x && y > SIZE_MAX / x) {
               ^
/usr/include/jasper/jas_math.h: In function 'bool jas_safe_size_add(size_t, size_t, size_t*)':
/usr/include/jasper/jas_math.h:170:10: error: 'SIZE_MAX' was not declared in this scope
  if (y > SIZE_MAX - x) {
          ^
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes

~0029298

dom-f (reporter)

Also seeing the same issue - diwngraded to 29.el7_3 as workaround.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-18 14:34 george.wilson New Issue
2017-05-18 15:07 dom-f Note Added: 0029298
+Issue History