View Issue Details

IDProjectCategoryView StatusLast Update
0013286administrationoperationspublic2019-08-12 13:50
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Platformx86_64OScentosOS Version7
Product Version 
Target VersionFixed in Version 
Summary0013286: /usr/lib64/ version number is wrong
DescriptionI can't build a package that requires gpgme version >= 1.1.8, even though yum says I've got version 1.3.2 installed. Setting PKG_CONFIG_PATH to /usr/lib64 doesn't help, because the two (?) libraries there are named /usr/lib64/ and /usr/lib64/ The directory /usr/share/doc/gpgme-1.3.2 is also present, confirming yum's opinion of the currently installed version number. But "yum info" also says it came "From repo : anaconda".

Can anyone help me make sense out of these conflicting data?
Steps To Reproduceyum info gpgme.x86_64

ls /usr/lib64/libgmgmp*
TagsNo tags attached.




2017-05-21 19:29

reporter   ~0029306

Actually, the problem is probably due to the fact that nothing matches *gpgme* in /usr/lib64/pkgconfig. But why?


2017-05-23 01:34

reporter   ~0029311

Nobody could reproduce this bug because the steps shown in "Steps to Reproduce" doesn't.
What's the exact package requiring the gpgme >= 1.1.8 ?
Does the SPEC file literally say "BuildRequires gpgme >= 1.1.8" ?


2017-05-23 16:59

reporter   ~0029318

The issue cropped up while running "./configure" for ostree 2017.6. FYI I've attached the config.log file.

config.log (49,333 bytes)


2017-05-23 17:16

reporter   ~0029319

Or at least, I tried to attach it using the "Upload File" field below. If that didn't work please let me know how best to get it to you.


2017-05-24 06:59

reporter   ~0029327

> configure:14476: $PKG_CONFIG --exists --print-errors "gpgme-pthread >= $LIBGPGME_DEPENDENCY"
> Package gpgme-pthread was not found in the pkg-config search path.
> Perhaps you should add the directory containing `gpgme-pthread.pc'
> to the PKG_CONFIG_PATH environment variable
> No package 'gpgme-pthread' found
> configure:14479: $? = 1

CentOS 7's gpgme package doesn't provide pkg-config gpgme-pthread.pc file.
Are you sure that "ostree" is supported under CentOS 7?

Upstream GnuPG seems to have this file exported very recently
so you may get around by compiling the latest gpgme by yourself.
Don't pick and install a random gpgme-1.9.0.whatever.rpm over CentOS ones
unless you're ready for full reinstall.

At least this is not a CentOS bug.

Issue History

Date Modified Username Field Change
2017-05-20 21:31 tfhavel New Issue
2017-05-21 19:29 tfhavel Note Added: 0029306
2017-05-23 01:34 kabe Note Added: 0029311
2017-05-23 16:59 tfhavel File Added: config.log
2017-05-23 16:59 tfhavel Note Added: 0029318
2017-05-23 17:16 tfhavel Note Added: 0029319
2017-05-24 06:59 kabe Note Added: 0029327
2019-08-12 13:50 TrevorH Status new => closed
2019-08-12 13:50 TrevorH Resolution open => won't fix