View Issue Details

IDProjectCategoryView StatusLast Update
0013353BuildsysCi.centos.org Ecosystem Testingpublic2017-07-05 20:51
Reporterhectorj2f 
PriorityhighSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Platformdevtools teamOSOS Version
Summary0013353: Account to manage https://ci.centos.org
DescriptionHi,

My name is Hector Fernandez. I belong to the devtools - platform team, we need to get an admin account to be able to enable/disable jobs in jenkins. Moreover, I could see that the jenkins slaves are getting slow and jobs are hanging or taking longer. So I will like to be able to dig into this problem.
TagsNo tags attached.

Activities

hectorj2f

hectorj2f

2017-06-01 10:13

reporter   ~0029381

I made a mistake in the category, I want an account for the CI Testing ecosystem

id_rsa.pub (414 bytes)
arrfab

arrfab

2017-06-02 11:19

administrator   ~0029393

Last edited: 2017-06-02 11:20

View 2 revisions

We can discuss that with bstinson, but we don't allow external people to get admin access in Jenkins (as also decided by KB)
For the job definitions, it also should happen through JJB (and Brian can comment or give explanations)

bstinson

bstinson

2017-06-05 20:50

developer   ~0029405

Hi Hector,

Under what circumstances would you need to disable jobs? It's probably best to work this through pull requests on the JJB templates (for tracking purposes).

--Brian
hectorj2f

hectorj2f

2017-06-06 14:44

reporter   ~0029410

Hi Brian,

Maybe a simple user account might work, not necessarily admin. But we were having many problems the previous week, and we couldn't do anything to solve them, or at least to dig deeper to know what was going on.

We experienced problems with the github hooks and problems related to jobs not being triggered by jenkins(probably due to slow slaves).

Also there was a situation where one developer had a job hanging forever and nobody was able to kill it or stop it inside jenkins. In order to speed up, it could be good if we can also do this kind of minor operations to speed up or to solve these problems.
hectorj2f

hectorj2f

2017-06-12 09:49

reporter   ~0029445

Hi there,

Please, could someone tell me if I'll get a simple user account like Pete has ?

Thanks in advance.
kbsingh@karan.org

kbsingh@karan.org

2017-06-12 16:13

administrator   ~0029450

+1 from me, we can get hector on there - ideally we want to keep the list of people with direct accounts low. we want to ensure that the entire job tracks have an audit log so we can go back if needed and evaluate.

Issue History

Date Modified Username Field Change
2017-06-01 10:08 hectorj2f New Issue
2017-06-01 10:13 hectorj2f File Added: id_rsa.pub
2017-06-01 10:13 hectorj2f Note Added: 0029381
2017-06-02 11:18 arrfab Category Ci.Dev Distro Testing => Ci.centos.org Ecosystem Testing
2017-06-02 11:19 arrfab Note Added: 0029393
2017-06-02 11:20 arrfab Note Edited: 0029393 View Revisions
2017-06-05 20:50 bstinson Note Added: 0029405
2017-06-06 14:44 hectorj2f Note Added: 0029410
2017-06-12 09:49 hectorj2f Note Added: 0029445
2017-06-12 16:13 kbsingh@karan.org Note Added: 0029450
2017-07-05 20:51 bstinson Status new => resolved
2017-07-05 20:51 bstinson Resolution open => fixed