View Issue Details

IDProjectCategoryView StatusLast Update
0000134websitewebsitepublic2004-02-10 05:19
Reporterherrold 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOtherOSotherOS Version
Product Versionunspecified 
Target VersionFixed in Version 
Summary0000134: bad Epoch advice needs to be removed
DescriptionThis page was done very early, and has clear errors. Please add a
<strike></strike> on the section reading:

    EPOCH tag: The EPOCH should always be stated in an RPM, and if the package
even if it is not used (ie. defined as 0 (zero)). Using the EPOCH tag should
only be done if absolutly necessary. The nature of cAos is to follow the
community thus it is a moving target, so if the EPOCH tag is incremented, it is
very hard (if even possiable) to decrement it over the life of that package.

as it is almost guaranteed to break pre-rpm-4.1 comparisons really really badly
for yum determinations. Please add in its place:

    If blank, the Epoch tag should be left blank. Epoch should be rarely used,
primarily to solve external developer versioning synchronization issues (and
this only rarely), and to permit clean automated movement to a lower numbered VR
as an update or upgrade path. Please consult the caos-devel mailing list
members for further details and usage suggestions.

----- replacement text ends
TagsNo tags attached.

Activities

greg@caosity.org

greg@caosity.org

2003-12-19 05:54

reporter   ~0000499

Last edited: 1970-01-01 00:00

Agreed. replacement text:

DONT TOUCH THE EPOCH!

:)
lance@uklinux.net

lance@uklinux.net

2003-12-20 22:44

reporter   ~0000500

Last edited: 1970-01-01 00:00

*** Bug 133 has been marked as a duplicate of this bug. ***
lance@uklinux.net

lance@uklinux.net

2003-12-23 00:43

reporter   ~0000501

Last edited: 1970-01-01 00:00

orcs changes posted

but was is VR ??
herrold

herrold

2004-02-10 05:19

reporter   ~0000502

Last edited: 1970-01-01 00:00

this change applied - thanks

Issue History

Date Modified Username Field Change
2003-12-20 22:44 lance@uklinux.net CC => m.stolte@datadevil.demon.nl
2004-02-10 05:19 herrold Status NEW => RESOLVED
2004-02-10 05:19 herrold Resolution => FIXED