View Issue Details

IDProjectCategoryView StatusLast Update
0013609AtomicDockerpublic2017-07-27 23:36
Reporterfunkypenguin 
PriorityhighSeveritymajorReproducibilityalways
Status newResolutionopen 
PlatformKVM-based VMOScentos-atomic-host/7/x86_64/stanOS Version7.1706
Summary0013609: docker-latest package can't install volume plugins due to missing /usr/libexec/docker/docker-runc
DescriptionI'm running the docker-latest package on Atomic, which I installed per https://seven.centos.org/2017/05/new-centos-atomic-host-with-optional-docker-1-13/

Docker works normally, so does swarm mode. However, when I try to install a volume plugin, the installation fails as below:

----
[root@ds3 data]# /usr/libexec/docker/docker-runc-latest^C
[root@ds3 data]# docker plugin install rexray/rbd RBD_DEFAULTPOOL=rbd
Plugin "rexray/rbd" is requesting the following privileges:
 - network: [host]
 - mount: [/dev]
 - mount: [/etc/ceph]
 - allow-all-devices: [true]
 - capabilities: [CAP_SYS_ADMIN]
Do you grant the above permissions? [y/N] y
Trying to pull repository docker.io/rexray/rbd ...
latest: Pulling from docker.io/rexray/rbd
78a53255c458: Download complete
Digest: sha256:160fc36e0e36179e8d6de669dbd79f7e4d8e94e4519e6380a0eea484b55b9f35
Status: Downloaded newer image for docker.io/rexray/rbd:latest
Error response from daemon: rpc error: code = 2 desc = shim error: docker-runc not installed on system
----
Steps To Reproduce1. Install CentOS Atomic
2. Switch to docker-latest per https://seven.centos.org/2017/05/new-centos-atomic-host-with-optional-docker-1-13/
3. Attempt to install a volume plugin (i.e. "docker plugin install rexray/rbd")

Installation will fail with error
Tagsdocker

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2017-07-27 23:36 funkypenguin New Issue
2017-07-27 23:36 funkypenguin Tag Attached: docker