2017-12-16 20:39 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0013858CentOS-7gnome-shellpublic2017-11-13 09:47
Reporterdgnani 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusnewResolutionopen 
PlatformOSOS Version7
Product Version 
Target VersionFixed in Version 
Summary0013858: [abrt] gnome-shell: invalid syntax (gnome-shell-extension-tool, line 152)
DescriptionDescription of problem:
In Centos 7.4.1708 (workstation), running at command prompt (tcsh)
> gnome-shell-extension-tool --help
  File "/usr/bin/gnome-shell-extension-tool", line 152
    print("%r is already enabled." % (uuid,), file=sys.stderr)
                                                  ^
SyntaxError: invalid syntax
>

Default python version is 2.7.5 while print syntax on line 152 and elsewhere is from Python 3

Had to modify script /usr/bin/gnome-shell-extension-tool by adding:
from __future__ import print_function

Version-Release number of selected component:
gnome-shell-3.22.3-17.el7

Truncated backtrace:
invalid syntax (gnome-shell-extension-tool, line 152)

  File "/usr/bin/gnome-shell-extension-tool", line 152
    print("%r is already enabled." % (uuid,), file=sys.stderr)
                                                  ^
SyntaxError: invalid syntax
Additional Informationreporter: libreport-2.1.11.1
cmdline: /usr/bin/python /usr/bin/gnome-shell-extension-tool --help
executable: /usr/bin/gnome-shell-extension-tool
kernel: 3.10.0-693.2.2.el7.x86_64
pkg_fingerprint: 24C6 A8A7 F4A8 0EB5
pkg_vendor: CentOS
runlevel: N 5
type: Python
uid: 1000
TagsNo tags attached.
abrt_hash4c126da2e917d18c30110674b382ee4a25a8b7be
URLhttps://retrace.fedoraproject.org/faf/reports/bthash/c06a8cc5abef7a413845b33d747748205dd31da0
Attached Files
  • ? file icon backtrace (253 bytes) 2017-09-19 20:29 -
    invalid syntax (gnome-shell-extension-tool, line 152)
    
      File "/usr/bin/gnome-shell-extension-tool", line 152
        print("%r is already enabled." % (uuid,), file=sys.stderr)
                                                      ^
    SyntaxError: invalid syntax
    
    ? file icon backtrace (253 bytes) 2017-09-19 20:29 +
  • ? file icon environ (2,744 bytes) 2017-09-19 20:29 -
    GNOME_DESKTOP_SESSION_ID=this-is-deprecated
    GJS_DEBUG_OUTPUT=stderr
    LESSOPEN=||/usr/bin/lesspipe.sh %s
    XDG_SESSION_TYPE=x11
    QT_IM_MODULE=xim
    
    XDG_VTNR=1
    
    WINDOWPATH=1
    SSH_AGENT_PID=2310
    LANG=en_US.UTF-8
    TERM=xterm-256color
    SHELL=/bin/bash
    
    SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2136,unix/unix:/tmp/.ICE-unix/2136
    SHLVL=2
    QT_QPA_PLATFORMTHEME=qgnomeplatform
    HISTSIZE=1000
    WINDOWID=39845894
    IMSETTINGS_INTEGRATE_DESKTOP=yes
    
    IMSETTINGS_MODULE=none
    XDG_RUNTIME_DIR=/run/user/1000
    SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
    VTE_VERSION=4602
    GDMSESSION=gnome-classic
    XMODIFIERS=@im=none
    GNOME_SHELL_SESSION_MODE=classic
    
    XDG_CURRENT_DESKTOP=GNOME-Classic:GNOME
    XDG_SESSION_ID=1
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-XyY5Ld2Ov4,guid=d8a23bd321c5b424cd5219e059c01390
    _=/usr/bin/gnome-shell-extension-tool
    DESKTOP_SESSION=gnome-classic
    DISPLAY=:0
    
    GDM_LANG=en_US.UTF-8
    HISTCONTROL=ignoredups
    
    COLORTERM=truecolor
    XDG_MENU_PREFIX=gnome-
    XDG_SESSION_DESKTOP=gnome-classic
    LS_COLORS=rs=0:di=38;5;27:ln=38;5;51:mh=44;38;5;15:pi=40;38;5;11:so=38;5;13:do=38;5;5:bd=48;5;232;38;5;11:cd=48;5;232;38;5;3:or=48;5;232;38;5;9:mi=05;48;5;232;38;5;15:su=48;5;196;38;5;15:sg=48;5;11;38;5;16:ca=48;5;196;38;5;226:tw=48;5;10;38;5;16:ow=48;5;10;38;5;21:st=48;5;21;38;5;15:ex=38;5;34:*.tar=38;5;9:*.tgz=38;5;9:*.arc=38;5;9:*.arj=38;5;9:*.taz=38;5;9:*.lha=38;5;9:*.lz4=38;5;9:*.lzh=38;5;9:*.lzma=38;5;9:*.tlz=38;5;9:*.txz=38;5;9:*.tzo=38;5;9:*.t7z=38;5;9:*.zip=38;5;9:*.z=38;5;9:*.Z=38;5;9:*.dz=38;5;9:*.gz=38;5;9:*.lrz=38;5;9:*.lz=38;5;9:*.lzo=38;5;9:*.xz=38;5;9:*.bz2=38;5;9:*.bz=38;5;9:*.tbz=38;5;9:*.tbz2=38;5;9:*.tz=38;5;9:*.deb=38;5;9:*.rpm=38;5;9:*.jar=38;5;9:*.war=38;5;9:*.ear=38;5;9:*.sar=38;5;9:*.rar=38;5;9:*.alz=38;5;9:*.ace=38;5;9:*.zoo=38;5;9:*.cpio=38;5;9:*.7z=38;5;9:*.rz=38;5;9:*.cab=38;5;9:*.jpg=38;5;13:*.jpeg=38;5;13:*.gif=38;5;13:*.bmp=38;5;13:*.pbm=38;5;13:*.pgm=38;5;13:*.ppm=38;5;13:*.tga=38;5;13:*.xbm=38;5;13:*.xpm=38;5;13:*.tif=38;5;13:*.tiff=38;5;13:*.png=38;5;13:*.svg=38;5;13:*.svgz=38;5;13:*.mng=38;5;13:*.pcx=38;5;13:*.mov=38;5;13:*.mpg=38;5;13:*.mpeg=38;5;13:*.m2v=38;5;13:*.mkv=38;5;13:*.webm=38;5;13:*.ogm=38;5;13:*.mp4=38;5;13:*.m4v=38;5;13:*.mp4v=38;5;13:*.vob=38;5;13:*.qt=38;5;13:*.nuv=38;5;13:*.wmv=38;5;13:*.asf=38;5;13:*.rm=38;5;13:*.rmvb=38;5;13:*.flc=38;5;13:*.avi=38;5;13:*.fli=38;5;13:*.flv=38;5;13:*.gl=38;5;13:*.dl=38;5;13:*.xcf=38;5;13:*.xwd=38;5;13:*.yuv=38;5;13:*.cgm=38;5;13:*.emf=38;5;13:*.axv=38;5;13:*.anx=38;5;13:*.ogv=38;5;13:*.ogx=38;5;13:*.aac=38;5;45:*.au=38;5;45:*.flac=38;5;45:*.mid=38;5;45:*.midi=38;5;45:*.mka=38;5;45:*.mp3=38;5;45:*.mpc=38;5;45:*.ogg=38;5;45:*.ra=38;5;45:*.wav=38;5;45:*.axa=38;5;45:*.oga=38;5;45:*.spx=38;5;45:*.xspf=38;5;45:
    GJS_DEBUG_TOPICS=JS ERROR;JS LOG
    XDG_SEAT=seat0
    
    ? file icon environ (2,744 bytes) 2017-09-19 20:29 +
  • ? file icon machineid (135 bytes) 2017-09-19 20:29 -
    systemd=7ad58669c8174fdc99ad00e5d3d49682
    sosreport_uploader-dmidecode=b12a5fc8e1b48755f5108abb6f59a9392fd04a9036046bfa09e5d8d10c750600
    
    ? file icon machineid (135 bytes) 2017-09-19 20:29 +

-Relationships
+Relationships

-Notes

~0030567

morteza.bashsiz@gmail.com (reporter)

Another user experienced a similar problem:

when i add gnome shell extentions (monitor)
I do step by step from following link
https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet

reporter: libreport-2.1.11.1
cmdline: /usr/bin/python /usr/bin/gnome-shell-extension-tool --enable-extension=system-monitor@paradoxxx.zero.gmail.com
executable: /usr/bin/gnome-shell-extension-tool
kernel: 3.10.0-693.2.2.el7.x86_64
package: gnome-shell-3.22.3-17.el7
pkg_fingerprint: 24C6 A8A7 F4A8 0EB5
pkg_vendor: CentOS
reason: invalid syntax (gnome-shell-extension-tool, line 152)
reproducible: The problem occurs regularly
runlevel: N 5
type: Python
uid: 1000
+Notes

-Issue History
Date Modified Username Field Change
2017-09-19 20:29 dgnani New Issue
2017-09-19 20:29 dgnani File Added: backtrace
2017-09-19 20:29 dgnani File Added: environ
2017-09-19 20:29 dgnani File Added: machineid
2017-11-13 09:47 morteza.bashsiz@gmail.com Note Added: 0030567
+Issue History