View Issue Details

IDProjectCategoryView StatusLast Update
0013896CentOS-6kernelpublic2017-09-24 16:25
Reportersouravm 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionno change required 
PlatformLinuxOSCentOS6OS Version4.13.3
Product Version6.9 
Target VersionFixed in Version 
Summary0013896: System Boot Problem - LUKS+kernel 4.13.3
DescriptionI am facing booting problem after upgrading kernel to 4.13.3 on CentOS 6 having LUKS encryption (cryptsetup-luks-1.2.0-11.el6.x86_64). I tried compiling the same kernel on another CentOS6 which does not have LUKS volume, that works without any issue. But I am facing issue on the servers having LUKS volume. During booting, the system is asking encryption password and after that there is no progress. I have attached the screenshot. Kindly suggest.

TagsNo tags attached.

Activities

souravm

souravm

2017-09-24 04:58

reporter  

SystemHalted.PNG (10,090 bytes)
SystemHalted.PNG (10,090 bytes)
tigalch

tigalch

2017-09-24 06:17

manager   ~0030187

We do not support other kernels then those we ship. If you need the current kernel, you can try the one from ElRepo - allready packages for EL6
souravm

souravm

2017-09-24 09:22

reporter   ~0030191

Thanks for your response.

The issue is resolved after creating "initramfs" with "mod_crypt" and "mod_dm" modules

# mkinitrd initramfs-4.13.3.img 4.13.3 --with=mod_crypt --with=mod_dm
tigalch

tigalch

2017-09-24 16:25

manager   ~0030192

Marking as SOVLED

Issue History

Date Modified Username Field Change
2017-09-24 04:58 souravm New Issue
2017-09-24 04:58 souravm File Added: SystemHalted.PNG
2017-09-24 06:17 tigalch Note Added: 0030187
2017-09-24 09:22 souravm Note Added: 0030191
2017-09-24 16:25 tigalch Status new => resolved
2017-09-24 16:25 tigalch Resolution open => no change required
2017-09-24 16:25 tigalch Note Added: 0030192