View Issue Details

IDProjectCategoryView StatusLast Update
0013990CentOS-7kernelpublic2018-01-24 22:54
ReporterChad.Farmer 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Platformx86_64OSCentOSOS Version7.3.1611
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0013990: Kernel build gives misleading message if openssl-devel is missing.
DescriptionBuilding a Linux kernel rpm with the tools perf option requires that openssl-devel is installed to provide /usr/include/openssl/crypto.h. If openssl-devel is missing, the warning message says that libcrypto.h is missing and suggests installing libssl-devel or libssl-dev. Include file libcrypto.h and package libssl do not exist in the RedHat/CentOS world.

I suggest the following one-line change to the warning message.
--- linux-3.10.0-514.10.2.el7.PHX13.x86_64/tools/perf/config/Makefile.orig 2017-02-20 00:04:43.000000000 -0700
+++ linux-3.10.0-514.10.2.el7.PHX13.x86_64/tools/perf/config/Makefile 2017-10-06 11:49:20.349471608 -0700
@@ -395,7 +395,7 @@ endif

 ifndef NO_LIBCRYPTO
   ifneq ($(feature-libcrypto), 1)
- msg := $(warning No libcrypto.h found, disables jitted code injection, please install libssl-devel or libssl-dev);
+ msg := $(warning No crypto.h found, disables jitted code injection, please install openssl-devel);
     NO_LIBCRYPTO := 1
   else
     CFLAGS += -DHAVE_LIBCRYPTO_SUPPORT
Steps To ReproduceBuild kernel RPM without installing package openssl-devel.
Additional InformationIn addition, the kernel.spec file should probably add openssl-devel to the "with_perf" BuildRequires packages. The kernel has a NO_LIBCRYPTO option, but that should not conflict with adding a BuildRequires for openssl-devel.
TagsNo tags attached.
abrt_hash
URL

Activities

toracat

toracat

2017-10-07 21:15

manager  

bug13990.patch (517 bytes)
--- a/tools/perf/Makefile.config	2017-09-09 00:06:42.000000000 -0700
+++ b/tools/perf/Makefile.config	2017-10-07 14:12:43.689808032 -0700
@@ -468,7 +468,7 @@ endif
 
 ifndef NO_LIBCRYPTO
   ifneq ($(feature-libcrypto), 1)
-    msg := $(warning No libcrypto.h found, disables jitted code injection, please install libssl-devel or libssl-dev);
+    msg := $(warning No crypto.h found, disables jitted code injection, please install openssl-devel);
     NO_LIBCRYPTO := 1
   else
     CFLAGS += -DHAVE_LIBCRYPTO_SUPPORT
bug13990.patch (517 bytes)
toracat

toracat

2017-10-07 21:20

manager   ~0030322

Could you file a bug report on http://bugzilla.redhat.com so that this get fixed in the upstream (RHEL) kernel? This is the only way for CentOS to have the patch in their distro kernel.

What CentOS can do is to make the suggested changes to the centosplus kernel.
toracat

toracat

2017-10-07 21:21

manager   ~0030323

Since your patch is against the el7.3 kernel, I've uploaded the one for el7.4.
toracat

toracat

2017-10-19 17:25

manager   ~0030417

kernel-plus-3.10.0-693.5.2.el7.centos.plus has the changes requested.
Chad.Farmer

Chad.Farmer

2017-10-19 20:20

reporter   ~0030419

Pardon my ignorance, but I don't see kernel-plus-3.10.0-693.5.2.el7.centos.plus (or kernel-plus-3.10.0-693.5.2.el7.centos.plus.x86_64.rpm) under http://mirror.centos.org/centos/7/centosplus/x86_64/Packages/.
Chad.Farmer

Chad.Farmer

2017-10-19 20:23

reporter   ~0030420

Have you considered my suggestion to add openssl-devel to the "with perf" dependency list in kernel.spec?
toracat

toracat

2017-10-19 20:34

manager   ~0030421

@Chad.Farmer

That kernel will be published in due course. The source rpm has been submitted to @JohnnyHughes.

Yes, the suggested 'Requires' has been added to the spec file.
Chad.Farmer

Chad.Farmer

2017-10-19 20:36

reporter   ~0030422

Re: Pardon my ignornace: Of course the fix only affects the source rpm and the kernel build process. Binary kernel rpms don't show the change.
toracat

toracat

2018-01-24 22:54

manager   ~0031018

Marking this as 'resolved' as the requested changes have been in the plus kernel.

Issue History

Date Modified Username Field Change
2017-10-06 19:12 Chad.Farmer New Issue
2017-10-06 19:44 toracat Status new => acknowledged
2017-10-07 21:15 toracat File Added: bug13990.patch
2017-10-07 21:20 toracat Note Added: 0030322
2017-10-07 21:21 toracat Note Added: 0030323
2017-10-19 17:25 toracat Note Added: 0030417
2017-10-19 17:26 toracat Status acknowledged => assigned
2017-10-19 20:20 Chad.Farmer Note Added: 0030419
2017-10-19 20:23 Chad.Farmer Note Added: 0030420
2017-10-19 20:34 toracat Note Added: 0030421
2017-10-19 20:36 Chad.Farmer Note Added: 0030422
2018-01-24 22:54 toracat Status assigned => resolved
2018-01-24 22:54 toracat Resolution open => fixed
2018-01-24 22:54 toracat Note Added: 0031018