View Issue Details

IDProjectCategoryView StatusLast Update
0001402CentOS-4kernelpublic2006-08-23 13:47
ReporterMilan Kerslager 
PrioritynormalSeveritycrashReproducibilityalways
Status feedbackResolutionreopened 
Product Version4.3 - i386 
Target VersionFixed in Version 
Summary0001402: Because you are using unfixed compiler, kernel crashing uder heavy I/O
DescriptionYou are using older compiler than Red Hat does on recent kernel (at least kernel-2.6.9-34.0.1.EL and the latest kernel-2.6.9-34.0.2.EL). This is PLAIN WRONG since beta channel contains needed GCC & others.

Please, make sure you are using similar GCC to compile the kernel. Using old and unfixed compiler leads to crashes and kernel hangs (here on an heavy-loaded Athlon machine). This is very unproffesional.

I tryed to use Red Hat's kernel since I'm paying for several machines to Red Hat. This machine did not crashed since kernel change to the kernel compiled by recent version of GCC.
Additional InformationThis is Red Hat's version of the current kernel:
$ cat /proc/version
Linux version 2.6.9-34.0.2.ELsmp (bhcompile@hs20-bc1-2.build.redhat.com) (gcc version 3.4.6 20060404 (Red Hat 3.4.6-2)) #1 SMP Fri Jun 30 10:32:04 EDT 2006

This is your current kernel:
$ cat /proc/version
Linux version 2.6.9-34.0.2.EL (buildcentos@v20z-i386) (gcc version 3.4.5 20051201 (Red Hat 3.4.5-2)) #1 Fri Jul 7 19:24:57 CDT 2006
TagsNo tags attached.

Activities

Milan Kerslager

Milan Kerslager

2006-07-09 15:17

reporter   ~0003626

This seems to be related to bug #1306. I have random kernel OOPSes with CentOS kernel, but not with the same RH's kernel compiled by newer compiler.
herrold

herrold

2006-07-10 00:57

reporter   ~0003627

Red Hat has chosen to relese software build with a compiler they have not released. We (were when we saw the binary update, and) are aware of the variance; as the compiler variant in question has not been released, we invite you to ask them to release it
Milan Kerslager

Milan Kerslager

2006-07-11 21:33

reporter   ~0003630

If you ever heard about GPL and souces (with patches), I bet you know that any source is freely redistributable. So you are able to use sources from Beta channel from Red Hat even you are not paying for their supoort (support and only support).

If you are compiling the kernel with old compiler and you already know that this leads to random oopses, you are doing a really BAD JOB and this is very, very BAD.
gpanula

gpanula

2006-07-11 22:46

reporter   ~0003631

From http://kbase.redhat.com/faq/FAQ_58_6227.shtm

"You can use the following steps to add child channels such as Red Hat Application Server, Red Hat Cluster Suite, Red Hat Developer Suite, Red Hat Enterprise Linux AS/ES/WS Extras, and numerous Beta channels. Child channels will only be available for a valid subscription. Use the Channels tab to view the software channels available for your account."

~~~
The mystical "Beta" channel is only available if you have a paid subscription. One can confirm this by creating a free account at https://rhn.redhat.com and clicking on "Channels"; no channels listed.
herrold

herrold

2006-07-12 04:49

reporter   ~0003632

Milan

While you are welcome to be critical, unless you can obtain, or wish to address this issue with Red Hat on your own account, and not in the name of cCentOS, and can obtain the needed version, I do not see that we have much more to talk about here.

- Russ Herrold
JohnnyHughes

JohnnyHughes

2006-07-16 17:31

administrator   ~0003695

The upstream provider builds items using non released toolchains all the time.

That is what is unprofessional.

They have not released the gcc/glibc combination that they built the kernel in question with (though I wish they would).
JohnnyHughes

JohnnyHughes

2006-07-16 18:08

administrator   ~0003696

oh ... and just for the record, the gcc in the beta channel is 3.4.6-3 ... not 3.4.6-2 (which is used to build the upstream kernel).

I guess I could use a newer (and beta / not tested or released) gcc ... OR ... I could use what we (and they) currently have as stable.

Either option can cause problems ... I chose to use stable.
Milan Kerslager

Milan Kerslager

2006-07-16 18:14

reporter   ~0003697

Your decision is wrong because you are building kernel that crashes even you know about this.

I'm wondering why you don't have one subscription when you are using ALL that from Red Hat. I'm using clones of RHEL and I'm paying them because I would like to give them alt least small "thak you".

I don't underestand why you are doing this. Wrong compiler, broken kernels, you don't write about your changes to the SPEC %changelog... Do you know what is to give something back? Do you know why is better to not ship broken things?
herrold

herrold

2006-07-16 23:43

reporter   ~0003698

> You are using older compiler than Red Hat does on recent kernel (at
> least kernel-2.6.9-34.0.1.EL and the latest kernel-2.6.9-34.0.2.EL).
> This is PLAIN WRONG since beta channel contains needed GCC & others.

The version they are building with is not shipped, in the beta channel or elsewhere

> Please, make sure you are using similar GCC to compile the kernel. Using
> old and unfixed compiler leads to crashes and kernel hangs (here on
> an heavy-loaded Athlon machine). This is very unproffesional.

No - unprofessional is not responding to the request that you obtain what you seek to have us use from the prople who have it. Using a later 'beta' grade gcc offers no demonstrable improvement, other than on an anecdotal basis.

You are welcome to buy a subscription - I am pretty sure that all of the core taem have access to the RHEL channels through duly purchased and registered copies - the issue is not a fault on the part of the centos team - the PVAELV has chosen to to provide its toolchain.
JohnnyHughes

JohnnyHughes

2006-07-17 10:07

administrator   ~0003701

When you are running your distro ... you build on what you want.

When I am running mine ... I will do the same.

If you don't like it, use another distro
Milan Kerslager

Milan Kerslager

2006-08-23 11:39

reporter   ~0003828

You are kidding.

Why are you angry? Because you are bulding broken kernel even this is easy possible to build non-broken?
Milan Kerslager

Milan Kerslager

2006-08-23 12:10

reporter   ~0003829

GNU GPL allow use source without relation to the method original distributor decide to publish sources. So there is no reason to not use SRC from beta channel.

You never will have 3.4.6-2 GCC (or same binutils) because even after release with U4 there will be 3.4.6-2 or later version. So this reason is not real reason.

If you are unsure, read GPL and FAQ for GPL.

If people from RH has a reason to not use older compiler, you should think about it seriously because the change has a real practical and technical reason. Your reason does is not any of them. Only ideological.
JohnnyHughes

JohnnyHughes

2006-08-23 12:50

administrator   ~0003831

not having 3.4.6-2 is absolutely the real reason ...

I had 2 compilers (and glibc's to choose from)

3.4.6-3 (from 4.4 beta) and 3.4.5-2 from 4.3 ... and the beta glibc or the stable glibc.

Upstream built with 3.4.6-2 ... which they did not release.

If they has used 3.4.6-3 to build ... I would have used that. They did not. Building with beta released software that was not used upstream will never happen in CentOS.
Milan Kerslager

Milan Kerslager

2006-08-23 13:47

reporter   ~0003833

3.4.6-3 has 4 more bugs fixed. This is stable branch not devel. So only 4 bugfixes.

Crashing kernel is better? No. So you have/had only political reasons because 3.4.6-3 is now stable.

You picked up worstest way to do your job. Why?

Issue History

Date Modified Username Field Change
2006-07-09 09:18 Milan Kerslager New Issue
2006-07-09 09:18 Milan Kerslager Status new => assigned
2006-07-09 15:17 Milan Kerslager Note Added: 0003626
2006-07-10 00:57 herrold Note Added: 0003627
2006-07-11 21:33 Milan Kerslager Note Added: 0003630
2006-07-11 22:46 gpanula Note Added: 0003631
2006-07-12 04:49 herrold Note Added: 0003632
2006-07-16 17:31 JohnnyHughes Note Added: 0003695
2006-07-16 18:08 JohnnyHughes Note Added: 0003696
2006-07-16 18:14 Milan Kerslager Note Added: 0003697
2006-07-16 23:43 herrold Status assigned => resolved
2006-07-16 23:43 herrold Resolution open => not fixable
2006-07-16 23:43 herrold Note Added: 0003698
2006-07-17 10:07 JohnnyHughes Note Added: 0003701
2006-08-23 11:39 Milan Kerslager Status resolved => feedback
2006-08-23 11:39 Milan Kerslager Resolution not fixable => reopened
2006-08-23 11:39 Milan Kerslager Note Added: 0003828
2006-08-23 12:10 Milan Kerslager Note Added: 0003829
2006-08-23 12:50 JohnnyHughes Note Added: 0003831
2006-08-23 13:47 Milan Kerslager Note Added: 0003833