View Issue Details

IDProjectCategoryView StatusLast Update
0014072CentOS-7emacspublic2017-10-31 06:14
Reportertrialcritic 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformIntel x86_64OSCentOS 7OS Version7.4
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014072: Emacs crashes
DescriptionWhen I install emacs and run it, I get

Segmentation fault (core dumped)
Steps To Reproducesudo yum install emacs
emacs
Additional InformationIf I try downloading a version of emacs from web

https://ftp.gnu.org/gnu/emacs/emacs-25.3.tar.xz
tar zxf emacs-25.3.xz
cd emacs-25.3
./configure
make

I get a crash

./temacs --batch --load loadup bootstrap
make[1]: *** [bootstrap-emacs] Segmentation fault (core dumped)
make[1]: Leaving directory `/home/test/code/emacs-25.3/src'
make: *** [src] Error 2

I have no workarounds
TagsNo tags attached.
abrt_hash
URL

Activities

tigalch

tigalch

2017-10-30 17:56

manager   ~0030487

emacs is provided by CentOS, no need to build from source.
Use that version please.
trialcritic

trialcritic

2017-10-30 18:48

reporter   ~0030488

I did not see an emacs and installed with yum, got the crash.
tigalch

tigalch

2017-10-30 19:48

manager   ~0030489

You describe a crash when installing/compiling from source. Do you also get that crash when using the provided emacs?
trialcritic

trialcritic

2017-10-30 19:54

reporter   ~0030490

I did not see emacs and installed it with yum. It installed.

When I ran emacs, I got my crash.

Following this, I tried to compile and it failed.
tigalch

tigalch

2017-10-30 20:03

manager   ~0030491

I just installed emacs via yum and started it without issues.
trialcritic

trialcritic

2017-10-30 20:06

reporter   ~0030492

Maybe a mistake in my path or libraries. It was fine a month ago, we did many changes since then and this mess.
trialcritic

trialcritic

2017-10-30 21:24

reporter   ~0030494

It is a LD_LIBRARY_PATH problem and is fixed.
tigalch

tigalch

2017-10-31 06:14

manager   ~0030497

Thus CLOSING per reporters feedback

Issue History

Date Modified Username Field Change
2017-10-30 17:34 trialcritic New Issue
2017-10-30 17:56 tigalch Note Added: 0030487
2017-10-30 18:48 trialcritic Note Added: 0030488
2017-10-30 19:48 tigalch Note Added: 0030489
2017-10-30 19:54 trialcritic Note Added: 0030490
2017-10-30 20:03 tigalch Note Added: 0030491
2017-10-30 20:06 trialcritic Note Added: 0030492
2017-10-30 21:24 trialcritic Note Added: 0030494
2017-10-31 06:14 tigalch Status new => resolved
2017-10-31 06:14 tigalch Resolution open => unable to reproduce
2017-10-31 06:14 tigalch Note Added: 0030497