2017-11-23 07:34 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0014105CentOS-7NetworkManagerpublic2017-11-09 16:22
Reportermseaman 
PrioritynormalSeveritymajorReproducibilityalways
StatusnewResolutionopen 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014105: vlan interface configuration fails with 'service network restart'
DescriptionAdding a VLAN interface to an existing untagged ethernet fails on the _second_ physical interface via 'ifup eno2.63' or 'service network restart', but:

  - setting an IP address via 'ip address add 172.17.2.66/30 dev eno2.63'
    and then bringing the link up works

  - adding the equivalent configuration onto the _first_ physical interface
    works as expected
Steps To Reproduce1) Create /etc/sysconfig/network-scripts/ifcfg-eno2.63 like so:

```
# cat ifcfg-eno2.63
DEVICE=eno2.63
BOOTPROTO=none
ONBOOT=yes
IPADDR=172.17.2.66
PREFIX=30
NETWORK=172.17.2.64
VLAN=yes
TYPE=Vlan
PHYSDEV=eno2
VLAN_ID=63
```

2) Attempt to bring up interface:

```
# ifup eno2.63
Error: Connection activation failed: Connection 'Vlan eno2.63' is not available on the device eno2.63 at this time.
```

3) Similarly 'service network restart' fails:

```
# systemctl -l status network
‚óŹ network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; bad; vendor preset: disabled)
   Active: failed (Result: exit-code) since Thu 2017-11-09 14:54:02 UTC; 1h 16min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 31698 ExecStop=/etc/rc.d/init.d/network stop (code=exited, status=0/SUCCESS)
  Process: 31970 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)

Nov 09 14:53:57 ntp0.ld4.int.gigaclear.net network[31970]: Bringing up interface eno1: Connection successfully activated (D-Bus active path: /org/freedesktop/NetworkManager/ActiveConnection/3)
Nov 09 14:53:57 ntp0.ld4.int.gigaclear.net network[31970]: [ OK ]
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net network[31970]: Bringing up interface eno2: RTNETLINK answers: Invalid argument
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net network[31970]: [ OK ]
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net network[31970]: Bringing up interface eno2.63: Error: Connection activation failed: Connection 'Vlan eno2.63' is not available on the device eno2.63 at this time.
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net network[31970]: [FAILED]
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net systemd[1]: network.service: control process exited, code=exited status=1
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net systemd[1]: Failed to start LSB: Bring up/down networking.
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net systemd[1]: Unit network.service entered failed state.
Nov 09 14:54:02 ntp0.ld4.int.gigaclear.net systemd[1]: network.service failed.
```

4) The eno2.63@eno2 interface is created, but without any IP configuration. Adding the desired configuration manually works:

```
# ip address add 172.17.2.66/30 dev eno2.63
# ip link eno2.63 up
```

Then:

```
# ping -c 5 172.17.2.65
PING 172.17.2.65 (172.17.2.65) 56(84) bytes of data.
64 bytes from 172.17.2.65: icmp_seq=1 ttl=64 time=0.623 ms
64 bytes from 172.17.2.65: icmp_seq=2 ttl=64 time=0.659 ms
64 bytes from 172.17.2.65: icmp_seq=3 ttl=64 time=0.583 ms
64 bytes from 172.17.2.65: icmp_seq=4 ttl=64 time=0.703 ms
64 bytes from 172.17.2.65: icmp_seq=5 ttl=64 time=0.715 ms

--- 172.17.2.65 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 4000ms
rtt min/avg/max/mdev = 0.583/0.656/0.715/0.056 ms
```

5) Modifying the config in (1) in the obvious way to apply to eno1 apparently succeeds without error.

Additional InformationI've seen the same effect on an HP Proliant DL380 G9 with eno ethernet interfaces and an HP Proliant DL360 G6 with enp2s0f interfaces.
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes
There are no notes attached to this issue.
+Notes

-Issue History
Date Modified Username Field Change
2017-11-09 16:22 mseaman New Issue
+Issue History