View Issue Details

IDProjectCategoryView StatusLast Update
0014107Cloud Instance SIG[All Projects] generalpublic2020-06-30 08:58
Status resolvedResolutionfixed 
Summary0014107: AWS C5 instance types unavailable with marketplace AMIs
DescriptionThe CentOS 7 (and 6) HVM AMIs in the AWS marketplace do not yet support the recently released C5 instance family.
Steps To Reproduce1. Go to AWS Console/EC2 service
2. Click "Launch Instance"
3. Go to AWS Marketplace, search for "CentOS"
4. Select "CentOS 7 (x86_64) - with Updates HVM"
5. Try to choose types beginning with c5.
Instance types above are grayed out. Error is: "This instance type is not compatible with the selected AMI."
TagsNo tags attached.




2017-11-12 00:37

reporter   ~0030562

I confirm the issue, C5 instances have significant improvements and are cheaper, compared to C4.


2017-11-14 19:54

reporter   ~0030573

This issue also occurs when attempting to change instance type. From c4.2xlarge to c5.xlarge: The instance configuration for this AWS Marketplace product is not supported.
Elastic Network Adapter ENA enabled
kernel 3.10.0-693.5.2.el7.x86_64

We were able to successfully change to a c5 last week, but this week no luck.


2017-11-15 22:22

reporter   ~0030588

Today I was able to successfully change the instance type from a c4.xlarge to a c5.xlarge, but when starting the instance up I get the error: Error starting instances
Enhanced networking with the Elastic Network Adapter (ENA) is required for the 'c5.large' instance type. Ensure that your instance is enabled for ENA.

Can confirm ENA is enabled.


2017-11-21 14:59

reporter   ~0030624

I've also hit this. It'd be great to confirm if this is something to fix on the Marketplace side (I believe you need to tell AWS which instances are supported) or more technical. So far I haven't been able to create a CentOS7 image that boots on C5 instances (with NVMe root volume) but I've only been looking for a few hours.


2017-11-21 16:15

reporter   ~0030630

If you're rolling your own CentOS 7 AMI and are encountering issues booting it on the c5's (but works with other instance families), try running these two before taking the AMI:

yum install dracut-config-generic
dracut -f

From AWS support:
In order to have the correct initramfs to be created with your script I had to install a package named "dracut-config-generic". This package provides the configuration to turn off the host specific initramfs generation with dracut and generates a generic image by default. This package includes a single configuration file for dracut:

| $ cat /usr/lib/dracut/dracut.conf.d/02-generic-image.conf
| hostonly="no"

After I installed this package and rebuild the initramfs with "dracut -f" it started to boot normally on C5s. You can note the size difference between the initramfs files:

* Before the installation of "dracut-config-generic":
-rw------- 1 root root 19719505 Nov 13 16:28 initramfs-3.10.0-693.5.2.el7.x86_64.img

* After the installation of "dracut-config-generic":
-rw------- 1 root root 46942834 Nov 15 01:01 initramfs-3.10.0-693.5.2.el7.x86_64.img


2017-11-27 16:06

reporter   ~0030657

Can confirm that @hhsnow's workaround works for me. Thanks!


2017-11-28 18:58

reporter   ~0030660

Dracut hasn't worked for us.
Still getting: Error starting instances
Enhanced networking with the Elastic Network Adapter (ENA) is required for the 'c5.large' instance type. Ensure that your instance is enabled for ENA.
Can confirm running modinfo ena that ENA is enabled.


2017-11-28 19:14

reporter   ~0030661

Is ENA enabled for your instance? Via command line:
aws ec2 describe-instances --instance-ids {instance_id} --query 'Reservations[].Instances[].EnaSupport'

If not (stop instance and):
aws ec2 modify-instance-attribute --instance-id {instance_id} --ena-support

To make the AMI automatically support ENA, you need to enable ENA on the instance before you create the image.

Note that if you're using an AMI based on the CentOS marketplace AMI (has marketplace product codes in the details), you'll need to wait until this ticket is resolved to launch on i5's


2017-12-01 21:56

reporter   ~0030692


"Q. Which operating systems/AMIs are supported on C5 Instances?

EBS backed HVM AMIs with support for ENA networking and booting from NVMe-based storage can be used with C5 instances. The following AMIs are supported on C5:
CentOS 7 or newer, ... "

When would CentOS 6 get support for running on latest AWS hardware?


2017-12-05 16:44

reporter   ~0030702

I would love to see an official CentOS 7 AMI with ENA support. Is this on the roadmap?


2017-12-06 13:10

reporter   ~0030708

I see Centos 1708_11 was released yesterday and it can boot the c5 instances. But it cannot boot m5 instances yet. When would m5 instances be supported?


2017-12-06 15:14

reporter   ~0030711

+1 for M5 compatibility. I thought the fix to enable C5 was going to enable M5 as well.


2017-12-06 15:36

reporter   ~0030712

Yep, me too :-)


2017-12-11 09:34

reporter   ~0030739

The M5 instance types are supported now as well.


2017-12-11 16:44

reporter   ~0030741

CentOS 7 is working fine with C5/M5 instances. Any similar support coming to CentOS 6 ?


2017-12-12 10:55

reporter   ~0030742

M5 and C5 are all still greyed out when launching CentOS 7 AMI.
Is there any other way to get this?


2017-12-19 17:03

reporter   ~0030788

With CentOS 6 I can't use C5 instances:
The instance configuration for this AWS Marketplace product is not supported. Please see the AWS Marketplace site for more information about supported instance types, regions, and operating systems.


2018-01-24 14:23

reporter   ~0031013

When picking centos 7 HVM ( version 1801_01 ) on AWS marketplace I get the same issue as the original reporter of this ticket. This worked on 10 Jan 2018. Release notes state C5 aws instance types are supported.


2018-01-30 17:51

reporter   ~0031116 is related to this issue.


2019-05-19 20:36

reporter   ~0034480

The latest AMIs, for example "CentOS 7 (x86_64) - with Updates HVM" version 1901_01 do have support for ENA baked in, but have other issues related to the "eth0" device that prevent them from working 100% correctly, the network service fails to start correctly for example. Various people in the bug tracker have offered partial solutions and workarounds for these issues.

I have integrated workarounds for 3 different variants of this problem in the form of cloud-init scripts that you can pass to a CentOS 7 HVM EC2 instance as instance data:

* - for an IPv4 only setup
* - for an IPv4 and IPv6 dual-stack setup

Launching the AMIs with these cloud-init scripts results in networking starting correctly, and in the latter case, as long as the instance has an IPv6 address assigned, it will result in the instance acquiring both usable IPv4 and IPv6 addresses.

The cloud-init configuration and the base image should still get fixed so that this Just Works out of the box without any special configuration, though.


2020-06-25 10:47

administrator   ~0037234

Do you have still the issue with recent released AMIs that are listed on ?
If no, we'll close this bug report


2020-06-25 10:47

administrator   ~0037235

in feedback mode and closing in some days if no report

Issue History

Date Modified Username Field Change
2017-11-09 21:30 hhsnow New Issue
2017-11-12 00:37 TECK Note Added: 0030562
2017-11-14 19:54 jonnytronic Note Added: 0030573
2017-11-15 22:22 jonnytronic Note Added: 0030588
2017-11-21 14:59 gorgonzolae Note Added: 0030624
2017-11-21 16:15 hhsnow Note Added: 0030630
2017-11-27 16:06 caboteria Note Added: 0030657
2017-11-28 18:58 jonnytronic Note Added: 0030660
2017-11-28 19:14 hhsnow Note Added: 0030661
2017-12-01 21:56 fkubota Note Added: 0030692
2017-12-05 16:44 nevsan Note Added: 0030702
2017-12-06 13:10 Stef62820 Note Added: 0030708
2017-12-06 15:14 nevsan Note Added: 0030711
2017-12-06 15:36 Stef62820 Note Added: 0030712
2017-12-11 09:34 Stef62820 Note Added: 0030739
2017-12-11 16:44 centosrocks Note Added: 0030741
2017-12-12 10:55 48Laws Note Added: 0030742
2017-12-19 17:03 komodin Note Added: 0030788
2018-01-24 14:23 harold.gikas Note Added: 0031013
2018-01-30 17:51 siebrand Note Added: 0031116
2019-05-19 20:36 obscurerichard Note Added: 0034480
2020-06-25 10:47 arrfab Note Added: 0037234
2020-06-25 10:47 arrfab Status new => feedback
2020-06-25 10:47 arrfab Note Added: 0037235
2020-06-30 08:58 arrfab Status feedback => resolved
2020-06-30 08:58 arrfab Resolution open => fixed