View Issue Details

IDProjectCategoryView StatusLast Update
0014111CentOS-7[All Projects] generalpublic2017-11-15 11:50
Status acknowledgedResolutionopen 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014111: CentOS 7.4 USB installer - media test always fails in UEFI mode (but legacy BIOS mode is successful)
DescriptionCentOS 7.4 (1708) in a USB media. The media test (default option unless you manually press the up arrow during boot to skip the test and go straight to install) fails when it is in UEFI mode - or it may finish, but then read errors will happen and will fail to proceed to the installer (sample screenshot is attached in this report; more screens and discussion in CentOS forum thread supplied in additional information section)

Booting to a BIOS mode (if supported by mobo) makes the media test pass flawlessly and consistently.

Note that despite the media test option never working and proceeding to the installer, the media itself is fine. My installers, for example, have been used dozens of times in a couple of weeks, resulting in perfectly good installs. It was only by chance that I decided to let the media test run its course that I accidentally discovered that the UEFI media test seems to never succeed. Further tests seem to confirm that it's only a quirk in UEFI mode; a BIOS mode boot suffers no problem.

Slight problem for machines that support both UEFI and BIOS. For UEFI-only machines, this may be a bigger problem, as there would be no reliable way to actually verify your USB install media is (still) good.
Steps To Reproduce1.) Make new USB flashdisk installer, using plain old dd, using the CentOS 7.4 image.
2.) Media test at boot prompt on UEFI machines. Will fail all the time, or complete the test but then end up with IO errors / SQUASHFS errors (sample screenshot provided) and not make it into the installer
3.) If you just skip the media test by choosing the option above it ("Install..." instead of the default "Test and install..." option), everything's fine.
4.) Try that exact same flashdisk on a non-UEFI machine. It will repeatedly pass the media test and end up on the installation screen.
Additional InformationAt the same time:
1.) I have a USB installer at home that already passed repeatedly in my non-UEFI machine.
2.) I brought that installer to work, so I can see if it passes on my UEFI machines, since I already know it passed repeatedly on non-UEFI
3.) It just keeps getting errors on the UEFI machines.

CentOS Forums thread where I first asked for help with this issue:

This thread contains the conclusion I got, from the testing I described there, that BIOS media test works, but the UEFI media test does not.
Tagsinstallation, usb




2017-11-10 10:57




2017-11-10 22:46

manager   ~0030557


I cannot reproduce the problem on my computer running in UEFI mode. Media test finishes and the installer kicks in just fine.


2017-11-11 01:29

reporter   ~0030558


That's actually a thought of mine - that it isn't necessarily a 100% UEFI issue, but perhaps only wonks out on certain UEFI environments or motherboards. I was hoping it wasn't that complicated so it's easier to trace, debug and fix, but alas, reality is what it is.

What I can do is gather all the UEFI motherboard models that fail, and compare to yours to see if. Unfortunately, I only have access to a very small minority of my machines now - we're in a for a very long weekend, so it'll be several days until I regain access to our cluster of servers at work.

I'll update this bug next week with all the UEFI mobo models at work and at home, and compare with yours (and other contributors who may chime in). Hopefully, these data will help us zero in on what's really going on.



2017-11-15 11:39

reporter   ~0030577

I can confirm this this as I cannot boot either the ISO or a USB image on my Dell M6800 with UEFI enabled. But when I switch back to Legacy boot (BIOS) its boots no problem and runs. This was not the case with 1611 so it would appear that the problem first started in 1708.

I should add I am running the newest BIOS Release Date: 24 May 2017.

Should you need any further information please let me know.



2017-11-15 11:43

manager   ~0030578

reclusivegeek: how did you create your USB stick? Test by using dd and see if the problem persists. If not then it is not the same problem.


2017-11-15 11:50

reporter   ~0030579

I have used tried using dd, etcher, disks, unetbootin and always get the same result. I actually does not show in the UEFI boot options at all.

Hope this helps


Issue History

Date Modified Username Field Change
2017-11-10 10:57 jvroig New Issue
2017-11-10 10:57 jvroig File Added: IMG-1217ac629de4cda6f88fb3e70c11ffb8-V.jpg
2017-11-10 10:57 jvroig Tag Attached: installation
2017-11-10 10:57 jvroig Tag Attached: usb
2017-11-10 17:06 toracat Status new => acknowledged
2017-11-10 22:46 toracat Note Added: 0030557
2017-11-11 01:29 jvroig Note Added: 0030558
2017-11-15 11:39 reclusivegeek Note Added: 0030577
2017-11-15 11:43 TrevorH Note Added: 0030578
2017-11-15 11:50 reclusivegeek Note Added: 0030579