2018-02-20 05:20 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0014121CentOS-6pythonpublic2017-12-09 17:54
Reportermitaka_g 
PrioritynormalSeverityblockReproducibilityalways
StatusnewResolutionopen 
PlatformOSCentOSOS Version6.7
Product Version 
Target VersionFixed in Version 
Summary0014121: Python devel fails to install
DescriptionWhen trying to install python-devel package this happens:

Loading mirror speeds from cached hostfile
 * base: mirrors.mit.edu
 * extras: mirror.tzulo.com
 * updates: mirror.solarvps.com
Resolving Dependencies
--> Running transaction check
---> Package python-devel.x86_64 0:2.6.6-66.el6_8 will be installed
--> Processing Dependency: python-libs(x86-64) = 2.6.6-66.el6_8 for package: python-devel-2.6.6-66.el6_8.x86_64
--> Processing Dependency: python = 2.6.6-66.el6_8 for package: python-devel-2.6.6-66.el6_8.x86_64
--> Running transaction check
---> Package python.x86_64 0:2.6.6-64.el6 will be updated
---> Package python.x86_64 0:2.6.6-66.el6_8 will be an update
--> Processing Dependency: python-libs(x86-64) = 2.6.6-66.el6_8 for package: python-2.6.6-66.el6_8.x86_64
---> Package python-devel.x86_64 0:2.6.6-66.el6_8 will be installed
--> Processing Dependency: python-libs(x86-64) = 2.6.6-66.el6_8 for package: python-devel-2.6.6-66.el6_8.x86_64
--> Finished Dependency Resolution
Error: Package: python-devel-2.6.6-66.el6_8.x86_64 (base)
           Requires: python-libs(x86-64) = 2.6.6-66.el6_8
           Installed: python-libs-2.6.6-64.el6.x86_64 (@base)
               python-libs(x86-64) = 2.6.6-64.el6
Error: Package: python-2.6.6-66.el6_8.x86_64 (base)
           Requires: python-libs(x86-64) = 2.6.6-66.el6_8
           Installed: python-libs-2.6.6-64.el6.x86_64 (@base)
               python-libs(x86-64) = 2.6.6-64.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

It looks like that python-devel is requiring python-libs 2.6.6-66.el6_8 and there is no such package.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0030734

avij (manager)

python-libs-2.6.6-66.el6_8.x86_64.rpm is available. If you are not seeing it, you may be excluding it for some reason. See grep -ri exclude /etc/yum*
+Notes

-Issue History
Date Modified Username Field Change
2017-11-13 14:29 mitaka_g New Issue
2017-12-09 17:54 avij Note Added: 0030734
+Issue History