View Issue Details

IDProjectCategoryView StatusLast Update
0014218Buildsyscommunity buildsyspublic2019-04-18 11:45
ReporterStellarTodd 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSCentOSOS Version6 and 7
Summary0014218: libgfortran.so.4 requires static linkage
Descriptiondevtoolset-7-gcc-gfortran-7.2.1-1.el6.x86_64

libgfortran.so.4 was dynamically linked with gcc and quadmath. This should be static linkage.

I discovered this when upgrading from devtoolset-4.

$ ldd /usr/lib64/libgfortran.so.3
    linux-vdso.so.1 => (0x00007ffcce7dc000)
    libm.so.6 => /lib64/libm.so.6 (0x00007fec96ff6000)
    libc.so.6 => /lib64/libc.so.6 (0x00007fec96c61000)
    /lib64/ld-linux-x86-64.so.2 (0x0000003000000000)
$ ldd /usr/lib64/libgfortran.so.4
    linux-vdso.so.1 => (0x00007ffda8ef5000)
    libquadmath.so.0 => /usr/lib64/libquadmath.so.0 (0x00007f54f3127000)
    libm.so.6 => /lib64/libm.so.6 (0x00007f54f2ea2000)
    libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00007f54f2c8c000)
    libc.so.6 => /lib64/libc.so.6 (0x00007f54f28f8000)
    /lib64/ld-linux-x86-64.so.2 (0x0000003000000000)
TagsNo tags attached.

Activities

alphacc

alphacc

2019-04-18 11:45

developer   ~0034207

old package. Closing old tickets

Issue History

Date Modified Username Field Change
2017-12-01 22:58 StellarTodd New Issue
2019-04-18 11:45 alphacc Status new => resolved
2019-04-18 11:45 alphacc Resolution open => fixed
2019-04-18 11:45 alphacc Note Added: 0034207