View Issue Details

IDProjectCategoryView StatusLast Update
0014275CentOS-7yumpublic2017-12-15 17:57
Reporternathan@nathanpeters.com Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Platformx86_64OSCentOS 7OS Version7.4
Product Version7.4.1708 
Summary0014275: yum incorrectly considers i386 packages to be updates to x86_64 packages
DescriptionAs of this morning, yum updates fail due to incompatible versions of notepadqq being released into the sea.fedorapeople.org repositories. The issue is that I have an x86_64 package, and running yum update considers an i386 package with a higher version number to be a valid update.

Steps To ReproduceSteps to Reproduce:
1.
sudo yum update notepadqq.x86_64

Expected Results:
yum update succeeds

Actual Results:
---> Package notepadqq.x86_64 0:0.46.1-0.el7.centos will be updated
---> Package notepadqq.i386 0:0.46.1-1.fc20 will be an update
[cut for brevity]
--> Finished Dependency Resolution
Error: Package: notepadqq-0.46.1-1.fc20.i386 (FedoraPeople-sea)
           Requires: libQt5WebKitWidgets.so.5
Error: Package: notepadqq-0.46.1-1.fc20.i386 (FedoraPeople-sea)
           Requires: libQt5WebKit.so.5
Additional InformationWhy is a package that is installed as the x86_64 version trying to 'update' to an i386 version?

I could understand this on an initial install, but I already had an x86_64 package installed and so a package for a different platform is definitely not a valid upgrade.

I was able to get around this by adding exclude=*.i386 to my yum.conf but this should not be necessary at all.

Things like this should work out of the box without requiring the user to tweak their systems because a sloppy release by a single developer breaks their entire system yum workflow.
TagsNo tags attached.
abrt_hash
URL

Relationships

has duplicate 0014279 new yum incorrectly considers i386 packages to be updates to x86_64 packages 

Activities

tigalch

tigalch

2017-12-15 06:17

manager   ~0030750

You are trying to update a CentOS-Package with one from fc20. That's not how it works, and you should stick to the version provided by CentOS. Otherwise you are on your own - thus closing this ticket.

Issue History

Date Modified Username Field Change
2017-12-15 03:35 nathan@nathanpeters.com New Issue
2017-12-15 06:17 tigalch Status new => closed
2017-12-15 06:17 tigalch Resolution open => no change required
2017-12-15 06:17 tigalch Note Added: 0030750
2017-12-15 17:57 tru Relationship added has duplicate 0014279