View Issue Details

IDProjectCategoryView StatusLast Update
0014399CentOS-7kernelpublic2018-06-10 08:34
PrioritynormalSeverityblockReproducibilityhave not tried
Status newResolutionopen 
PlatformSupermicro X10DRH-iTOSKernel 3.10.0-693.11.6OS Version7.4.1708
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014399: Kernel Deadlock
DescriptionThe recent kernel (Version 3.10.0-693.11.6) with revoked microcode updates (active is Intel Microcode Version Ref. 0x3a 2017-01-30 for Haswell EP CPU, with activated PTI) has produced a kernel deadlock situation (10 of 12 threads blocked, 1x Haswell E5-2620 v3 with Hyperthreading) during heavy fileserver usage (NFSv3 and rsyncd).
The storage is based on mdraid,lvm and ext4 with a HBA Controller (LSI3008 chipset).
Details see in the attached kernel traces.
After this problem occurs, the storage access was blocked and the system had to be rebooted.
This setup was running with this fileserver load for the first time.

The system was running stable with the same kernel and the microcode
version ref. 0x3b (2017-11-17) for several days (12days).
Steps To Reproducenot tried to reproduce because the problem is too bad
TagsNo tags attached.




2018-01-22 13:46


kernel-3.10.0-693.11.6-deadlock.log (27,123 bytes)


2018-06-10 08:34

reporter   ~0032048

The problem is happening randomly since reported in January. Also with Centos 7.5.1804.
I have also KVM/libvirt running and therefore it could be related to this bug

Issue History

Date Modified Username Field Change
2018-01-22 13:46 kora New Issue
2018-01-22 13:46 kora File Added: kernel-3.10.0-693.11.6-deadlock.log
2018-06-10 08:34 kora Note Added: 0032048