View Issue Details

IDProjectCategoryView StatusLast Update
0014445BuildsysCi.centos.org Ecosystem Testingpublic2018-02-13 16:49
Reporterehelms 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionwon't fix 
Summary0014445: Add Ansible plugin to ci.centos.org
DescriptionThe Ansible plugin provides a nice DSL in Pipeline jobs for running Ansible playbooks. Please consider adding it to ci.centos.org.

https://wiki.jenkins.io/display/JENKINS/Ansible+Plugin
TagsNo tags attached.

Activities

arrfab

arrfab

2018-02-06 21:38

administrator   ~0031170

Just curious, can you give details about why one should use it instead of plain ansible-playbook call in the job ? Ourselves we have ansible jobs and when we tried the ansible-plugin it wasn't really adding added value. Worse : those days the plugin still tries to use -s for sudo instead of -b for become so you have deprecation warnings everywhere in the logs
bstinson

bstinson

2018-02-13 16:49

administrator   ~0031220

I'm closing this as WONTFIX because adding this plugin is probably not the right thing to do here. We don't store SSH keys in the jenkins credential store in ci.c.o for example.

If there's an ansible related convenience method we could add to our own pipeline library, though, I think we'd be open to that if someone is willing to help maintain.

Issue History

Date Modified Username Field Change
2018-02-01 02:45 ehelms New Issue
2018-02-06 21:38 arrfab Note Added: 0031170
2018-02-13 16:49 bstinson Status new => closed
2018-02-13 16:49 bstinson Resolution open => won't fix
2018-02-13 16:49 bstinson Note Added: 0031220