2018-02-19 13:54 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0014478CentOS-7pcsc-litepublic2018-02-11 16:16
Reportercparg 
PrioritynormalSeverityblockReproducibilityalways
StatusnewResolutionopen 
PlatformLaptop PCOSCentOS 7OS Version7.4.1708
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014478: Upgrade pcsc-lite-ccid and pcsc-lite
DescriptionThe Smart Card Reader which is built into the Dell Latitude 7480 (and others) is not recognized by pcsc-lite. The later versions of ccid-1.4.28 and pcsc-lite-1.8.23 do recognize this Broadcom reader though!
Therefore I kindly ask to upgrade the rpm packagages for el7!
Additional InformationMy build receipt:
(Note that some m4 macros have to be removed, since the el7 libtool is also outdated!)

sudo yum install libtool systemd-devel libusbx-devel

1. building pcsc-lite
wget https://alioth.debian.org/frs/download.php/file/4235/pcsc-lite-1.8.23.tar.bz2
tar -xvf pcsc-lite-1.8.23.tar.bz2
cd pcsc-lite-1.8.23
rm m4/libtool.m4 m4/ltoptions.m4 m4/ltversion.m4
./bootstrap
./configure --prefix=/ --libdir=/lib64
sudo make install

2. building ccid lib
wget https://alioth.debian.org/frs/download.php/file/4230/ccid-1.4.28.tar.bz2
tar -xvf ccid-1.4.28.tar.bz2
cd ccid-1.4.28/
./bootstrap
./configure --prefix=/ --libdir=/lib64
sudo make install
TagsNo tags attached.
abrt_hash
URL
Attached Files

-Relationships
+Relationships

-Notes

~0031210

TrevorH (developer)

Those packages are built as-is from RHEL source packages so you will need to report this on bugzilla.redhat.com to get it fixed. Once Redhat fix it in RHEL then CentOS will pick up the fix once the packages are released.
+Notes

-Issue History
Date Modified Username Field Change
2018-02-11 14:51 cparg New Issue
2018-02-11 16:16 TrevorH Note Added: 0031210
+Issue History