View Issue Details

IDProjectCategoryView StatusLast Update
0014498CentOS-7glusterfspublic2018-02-23 20:35
Reporterckotte 
PrioritynormalSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version7.3.1611 
Target VersionFixed in Version 
Summary0014498: nfs-ganesha-2.5.5-1.el7.x86_64 (centos-gluster312) can't be installed
DescriptionTried to deploy a new CentOS server. Can't install current nfs-ganesha version:

# yum install nfs-ganesha
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos-distro.cavecreek.net
 * epel: fedora-epel.mirror.lstn.net
 * extras: centos.host-engine.com
 * updates: centos.den.host-engine.com
Resolving Dependencies
--> Running transaction check
---> Package nfs-ganesha.x86_64 0:2.5.5-1.el7 will be installed
--> Processing Dependency: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit) for package: nfs-ganesha-2.5.5-1.el7.x86_64
--> Processing Dependency: libntirpc.so.1.5()(64bit) for package: nfs-ganesha-2.5.5-1.el7.x86_64
--> Running transaction check
---> Package libntirpc.x86_64 0:1.5.3-1.el7 will be installed
---> Package nfs-ganesha.x86_64 0:2.5.5-1.el7 will be installed
--> Processing Dependency: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit) for package: nfs-ganesha-2.5.5-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: nfs-ganesha-2.5.5-1.el7.x86_64 (centos-gluster312)
           Requires: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Steps To ReproduceInstallation/update on my other CentOS servers fail as well. Could install current version (nfs-ganesha-2.5.3-1) a few days ago on another box.
Additional Informationlooks like libntirpc-1.5.4-1.el7.x86_64 is not in the repository yet
TagsNo tags attached.
abrt_hash
URL

Activities

ppatterson

ppatterson

2018-02-19 15:39

reporter   ~0031251

Same problem with the update on both CentOS 6 and 7

---> Package nfs-ganesha.x86_64 0:2.5.3-1.el6 will be updated
---> Package nfs-ganesha.x86_64 0:2.5.5-1.el6 will be an update
--> Processing Dependency: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit) for package: nfs-ganesha-2.5.5-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: nfs-ganesha-2.5.5-1.el6.x86_64 (centos-gluster312)
           Requires: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit)
TomK

TomK

2018-02-20 02:08

reporter   ~0031252

Same error even with earlier versions up to 2.4.3-1 that I tested with if an earlier version of nfs-ganesha is already installed:

[root@nfs02 ganesha]# yum update nfs-ganesha-2.4.3-1.el7*
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
 * base: mirror.gpmidi.net
 * epel: ftp.cse.buffalo.edu
 * extras: mirror.gpmidi.net
 * updates: centos.zswap.net
Resolving Dependencies
--> Running transaction check
---> Package nfs-ganesha.x86_64 0:2.3.2-1.el7 will be updated
--> Processing Dependency: nfs-ganesha = 2.3.2-1.el7 for package: nfs-ganesha-vfs-2.3.2-1.el7.x86_64
--> Processing Dependency: nfs-ganesha = 2.3.2-1.el7 for package: nfs-ganesha-xfs-2.3.2-1.el7.x86_64
--> Processing Dependency: nfs-ganesha = 2.3.2-1.el7 for package: nfs-ganesha-gluster-2.3.2-1.el7.x86_64
---> Package nfs-ganesha.x86_64 0:2.4.3-1.el7 will be an update
--> Processing Dependency: libntirpc.so.1.4(NTIRPC_1.4.3)(64bit) for package: nfs-ganesha-2.4.3-1.el7.x86_64
--> Processing Dependency: libntirpc.so.1.4()(64bit) for package: nfs-ganesha-2.4.3-1.el7.x86_64
--> Running transaction check
---> Package libntirpc.x86_64 0:1.3.1-1.el7 will be updated
---> Package libntirpc.x86_64 0:1.4.3-1.el7 will be an update
---> Package nfs-ganesha-gluster.x86_64 0:2.3.2-1.el7 will be updated
---> Package nfs-ganesha-gluster.x86_64 0:2.5.5-1.el7 will be an update
--> Processing Dependency: nfs-ganesha = 2.5.5-1.el7 for package: nfs-ganesha-gluster-2.5.5-1.el7.x86_64
--> Processing Dependency: libntirpc.so.1.5()(64bit) for package: nfs-ganesha-gluster-2.5.5-1.el7.x86_64
---> Package nfs-ganesha-vfs.x86_64 0:2.3.2-1.el7 will be updated
---> Package nfs-ganesha-vfs.x86_64 0:2.5.5-1.el7 will be an update
---> Package nfs-ganesha-xfs.x86_64 0:2.3.2-1.el7 will be updated
---> Package nfs-ganesha-xfs.x86_64 0:2.5.5-1.el7 will be an update
--> Running transaction check
---> Package libntirpc.x86_64 0:1.3.1-1.el7 will be updated
---> Package libntirpc.x86_64 0:1.3.1-1.el7 will be updated
---> Package libntirpc.x86_64 0:1.4.3-1.el7 will be an update
---> Package libntirpc.x86_64 0:1.5.3-1.el7 will be an update
---> Package nfs-ganesha.x86_64 0:2.3.2-1.el7 will be updated
---> Package nfs-ganesha.x86_64 0:2.3.2-1.el7 will be updated
---> Package nfs-ganesha.x86_64 0:2.4.3-1.el7 will be an update
---> Package nfs-ganesha.x86_64 0:2.5.5-1.el7 will be an update
--> Processing Dependency: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit) for package: nfs-ganesha-2.5.5-1.el7.x86_64
--> Finished Dependency Resolution
Error: Package: nfs-ganesha-2.5.5-1.el7.x86_64 (centos-gluster312)
           Requires: libntirpc.so.1.5(NTIRPC_1.5.4)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@nfs02 ganesha]#

However, removing nfs-ganesha and only installing libntirpc.so.1.5.3 first:

[root@nfs02 ganesha]# rpm -aq|grep -Ei libntirpc
libntirpc-1.5.3-1.el7.x86_64
[root@nfs02 ganesha]#

Then installing a more recent version of nfs-ganesha, doesn't show the same error:

[root@nfs01 ganesha]# rpm -aq|grep -Ei "nfs-ganesha|libntirpc"
nfs-ganesha-2.5.3-1.el7.x86_64
libntirpc-1.5.3-1.el7.x86_64
[root@nfs01 ganesha]#

so can still some of the more recent packages.

Cheers,
Tom
pfaff

pfaff

2018-02-23 20:35

reporter   ~0031312

At this time, the missing libntirpc package is still in centos-gluster312-test, even though the nfs-ganesha-2.5.5 packages that depend on it have made it into centos-gluster312. To work around the problem, at this time, do:

  yum --enablerepo=centos-gluster312-test update

realizing, of course, that you'll then be using a package that is still in test.

Issue History

Date Modified Username Field Change
2018-02-16 22:21 ckotte New Issue
2018-02-19 15:39 ppatterson Note Added: 0031251
2018-02-20 02:08 TomK Note Added: 0031252
2018-02-23 20:35 pfaff Note Added: 0031312