View Issue Details

IDProjectCategoryView StatusLast Update
0014563Buildsyscommunity buildsyspublic2018-03-08 12:39
Reporterkkeithle 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Summary0014563: Storage SIG: create addtional CBS tags for GlusterFS-4.0
DescriptionSee https://bugs.centos.org/view.php?id=14362

Our plans have changed. We are going to build client-side only glusterfs-4.0 packages for el6 in the Storage SIG.

Please create el6 buildroots and tags for storage6-gluster-40-el6, similar to to the existing storage7-gluster-40-el7-build ones. (x86_64 only?)

Thanks,
TagsNo tags attached.

Activities

kkeithle

kkeithle

2018-03-07 16:12

reporter   ~0031375

We also need to add glusterd2 to storage7-gluster-40-{candidate,testing,release}

    https://cbs.centos.org/koji/taskinfo?taskID=351503
    BuildError: package glusterd2 not in list for tag storage7-gluster-40-candidate

thanks
kkeithle

kkeithle

2018-03-07 18:34

reporter   ~0031376

ignore the previous note. I added package myself.
kkeithle

kkeithle

2018-03-08 12:23

reporter   ~0031391

And we'll need http://mirror.centos.org/centos/6/storage/x86_64/gluster-4.0 too.

I had asked for this on https://bugs.centos.org/view.php?id=14543 but arrfab only did 7 (because no tags and no build yet.)
arrfab

arrfab

2018-03-08 12:39

administrator   ~0031392

So here we go :

* Checking distribution el6 configuration...
 -> Checking storage config...
Creating tag : storage6-gluster-40-candidate
Creating tag : storage6-gluster-40-testing
Creating tag : storage6-gluster-40-release
 -> creating storage6-gluster-40-el6
Added external repo centos6-extras to tag storage6-gluster-40-el6-build (priority 5)
Added external repo centos6-updates to tag storage6-gluster-40-el6-build (priority 10)
Added external repo centos6-os to tag storage6-gluster-40-el6-build (priority 15)
Adding storage6-gluster-common-candidate as inheritance
Adding storage6-common-candidate as inheritance

You can now build pkgs there, and follow the normal process
Once you're happy and you want to release to
- buildlogs (testing)
- mirror.centos.org (release)
open a separate bug report for this.

Issue History

Date Modified Username Field Change
2018-03-06 17:00 kkeithle New Issue
2018-03-07 16:12 kkeithle Note Added: 0031375
2018-03-07 18:34 kkeithle Note Added: 0031376
2018-03-08 12:23 kkeithle Note Added: 0031391
2018-03-08 12:39 arrfab Note Added: 0031392
2018-03-08 12:39 arrfab Status new => resolved
2018-03-08 12:39 arrfab Resolution open => fixed