View Issue Details

IDProjectCategoryView StatusLast Update
0014572CentOS-7CentOS-7-Pluspublic2018-03-12 13:13
ReporterAlpha Diallo 
Status closedResolutionno change required 
Product Version7.4.1708 
Target VersionFixed in Version 
Summary0014572: installation de bahmni version 0.90
I managed to install CentOS v7 on my i7 core server. But, I am having issues ,to install bahmni version 0.90, In fact bahmni requires the ansible- package wheras the CentOs v7XXXX has the ansible- package .el7.noarch.
In order to fix the issue, I removed the ansible- package and replaced it by the ansible- package. Thereafter, When I type the command: bahmni install, I am receiving the following error:
ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-installer/setup.yml'
/bin/sh: /bin/ansible-playbook : /usr/bin/python2.6 : mauvais interpr├ęteur: Aucun fichier ou dossier de ce type
Traceback (most recent call last):
  File "/bin/bahmni", line 9, in <module>
    load_entry_point('bahmni==0.1', 'console_scripts', 'bahmni')()
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 535, in invoke
    return callback(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "build/bdist.linux-x86_64/egg/", line 46, in install
  File "/usr/lib64/python2.7/", line 542, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-installer/setup.yml'' returned non-zero exit status 126

Can you help please?
Thank you in advance.

TagsNo tags attached.




2018-03-12 13:13

manager   ~0031412

First - the package bahmni - as far as I know - is not provided by CentOS. Please use the support venues from where you have that package.
Second - Don't install packages from EL6 on EL7 or vice versa, that means trouble all the way.

Issue History

Date Modified Username Field Change
2018-03-12 13:09 Alpha Diallo New Issue
2018-03-12 13:13 tigalch Status new => closed
2018-03-12 13:13 tigalch Resolution open => no change required
2018-03-12 13:13 tigalch Note Added: 0031412