View Issue Details

IDProjectCategoryView StatusLast Update
0014722CentOS-7python-backportspublic2018-04-29 16:53
Reporterschachtel Assigned To 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version7.4.1708 
Summary0014722: CentOS 7 CR Repo upgrade errors
DescriptionDownloading packages:
Not downloading deltainfo for cr, MD is 455 k and rpms are 13 k
python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch.rpm | 13 kB 00:00:00
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Aktualisieren : python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch 1/2
Error unpacking rpm package python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch
error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/backports.ssl_match_hostname-3.5.0.1-py2.7.egg-info: cpio: rename
  Überprüfung läuft: python-backports-ssl_match_hostname-3.5.0.1-1.el7.noarch 1/2
python-backports-ssl_match_hostname-3.4.0.2-4.el7.noarch was supposed to be removed but is not!
  Überprüfung läuft: python-backports-ssl_match_hostname-3.4.0.2-4.el7.noarch 2/2

Fehlgeschlagen:
  python-backports-ssl_match_hostname.noarch 0:3.4.0.2-4.el7 python-backports-ssl_match_hostname.noarch 0:3.5.0.1-1.el7
Steps To Reproduce1. enable CR- Repo
2. yum update
3. less errors
Tags7.5, update
abrt_hash
URL

Activities

TrevorH

TrevorH

2018-04-29 15:29

manager   ~0031692

This doesn't look like an error with the package, it looks like an error on your system.

 error: unpacking of archive failed on file /usr/lib/python2.7/site-packages/backports.ssl_match_hostname-3.5.0.1-py2.7.egg-info: cpio: rename

Is that file marked as immutable when you lsattr it?
schachtel

schachtel

2018-04-29 15:55

reporter   ~0031693

The right way. Thanks

Delete /usr/lib/python2.7/site-packages/backports.ssl_match_hostname-3.5.0.1-py2.7.egg-info

yum update

Bingo!
schachtel

schachtel

2018-04-29 16:01

reporter   ~0031694

We can close this issue.

Issue History

Date Modified Username Field Change
2018-04-29 10:46 schachtel New Issue
2018-04-29 10:46 schachtel Tag Attached: update
2018-04-29 10:58 schachtel Tag Attached: 7.5
2018-04-29 15:29 TrevorH Note Added: 0031692
2018-04-29 15:55 schachtel Note Added: 0031693
2018-04-29 16:01 schachtel Note Added: 0031694
2018-04-29 16:53 TrevorH Status new => closed
2018-04-29 16:53 TrevorH Resolution open => no change required