View Issue Details

IDProjectCategoryView StatusLast Update
0014761CentOS-7cockpitpublic2018-10-25 21:59
Reporterdylanmtaylor 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0014761: cockpit-storaged dependency issue on CentOS 7.5
DescriptionOn a CentOS 7.5 system, the cockpit-storaged component fails to install with dependency issues.
Steps To ReproduceRun yum install cockpit-storaged.
Additional Information[root@dylanmtaylor ~]# yum install cockpit-storaged
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.keystealth.org
 * elrepo: repos.lax-noc.com
 * elrepo-kernel: repos.lax-noc.com
 * epel: mirrors.develooper.com
 * extras: mirror.sigmanet.com
 * updates: centos.mirror.ndchost.com
Resolving Dependencies
--> Running transaction check
---> Package cockpit-storaged.noarch 0:160-1.el7.centos will be installed
--> Processing Dependency: storaged-lvm2 >= 2.1.1 for package: cockpit-storaged-160-1.el7.centos.noarch
Package storaged-lvm2-2.5.2-4.el7.x86_64 is obsoleted by udisks2-lvm2-2.7.3-6.el7.x86_64 which is already installed
--> Processing Dependency: storaged-iscsi >= 2.1.1 for package: cockpit-storaged-160-1.el7.centos.noarch
Package storaged-iscsi-2.5.2-4.el7.x86_64 is obsoleted by udisks2-iscsi-2.7.3-6.el7.x86_64 which is already installed
--> Processing Dependency: storaged >= 2.1.1 for package: cockpit-storaged-160-1.el7.centos.noarch
Package storaged-2.5.2-4.el7.x86_64 is obsoleted by udisks2-2.7.3-6.el7.x86_64 which is already installed
--> Finished Dependency Resolution
Error: Package: cockpit-storaged-160-1.el7.centos.noarch (extras)
           Requires: storaged-lvm2 >= 2.1.1
           Available: storaged-lvm2-2.5.2-4.el7.x86_64 (extras)
               storaged-lvm2 = 2.5.2-4.el7
Error: Package: cockpit-storaged-160-1.el7.centos.noarch (extras)
           Requires: storaged >= 2.1.1
           Available: storaged-2.5.2-4.el7.x86_64 (extras)
               storaged = 2.5.2-4.el7
Error: Package: cockpit-storaged-160-1.el7.centos.noarch (extras)
           Requires: storaged-iscsi >= 2.1.1
           Available: storaged-iscsi-2.5.2-4.el7.x86_64 (extras)
               storaged-iscsi = 2.5.2-4.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Tagscockpit
abrt_hash
URL

Activities

uniservice

uniservice

2018-05-11 14:19

reporter   ~0031762

This bug prevents a fresh install of Ovirt on CentOS 7.5
dylanmtaylor

dylanmtaylor

2018-05-11 23:15

reporter   ~0031777

Seems to be resolved in the latest packages.
uniservice

uniservice

2018-05-14 09:37

reporter   ~0031788

I can confirm, with the latest version of the package the bug seems resolved: i can (fresh) install and upgrade an Ovirt host without problem.
For the upgrade, could be necessary to do the next steps before starting upgrade from the engine:
- yum clean all && rm -rf /var/cache/yum
- yum reinstall -y cockpit-storaged cockpit-system cockpit

Thank's to the developers for the efforts done.

Issue History

Date Modified Username Field Change
2018-05-10 16:23 dylanmtaylor New Issue
2018-05-10 16:23 dylanmtaylor Tag Attached: cockpit
2018-05-11 14:19 uniservice Note Added: 0031762
2018-05-11 23:15 dylanmtaylor Note Added: 0031777
2018-05-14 09:37 uniservice Note Added: 0031788
2018-10-25 21:59 toracat Status new => resolved
2018-10-25 21:59 toracat Resolution open => fixed
2018-10-25 21:59 toracat Category -OTHER => cockpit